SI OU : trop d'arguments

Bonjour,

Je suis en train de codifier des données que j’ai obtenue suite à la diffusion d’un questionnaire. Selon le fichier Excel ci-joint, ma colonne A contient les données brut que je souhaite codée selon la codification mise sur mon fichier. Toutefois lorsque j’entre la formule ci-dessous, Excel m’indique que j’ai rentré trop d’arguments dans ma fonction… Que faire ?
FORUM 1.xlsx (15,4 Ko)

=SI(OU(DF5=« Je ne sais pas »);« 0 »;SI(OU(DF5=« Non »);« 1 »);SI(OU(DF5=« Connaissance »);« 2 »;SI(OU(DF5=« Ami »);« 3 »;SI(OU(DF5=« Famille »);« 4 »;SI(OU(DF5=« Moi »);« 5 »)))))

Bonjour,
Utilise plutôt RECHERCHEV
FORUM 1.xlsx (18,8 Ko)

Après si tu veux utiliser la fonction SI() (qui mangera beaucoup plus en, mémoire)
A mettre en B3

=SI(A3=$E$2;$F$2;SI(A3=$E$3;$F$3;SI(A3=$E$4;$F$4;SI(A3=$E$5;$F$5;SI(A3=$E$6;$F$6;SI(A3=$E$7;$F$7;""))))))

Super ça fonctionne ! Merci pour votre aide :grinning: