Problème fonction recherchev

RECAP.xlsx (12,7 Ko)

Bonjour,

J’ai un problème avec la fonction recherchev, je veux récupérer des infos (PRIX_MAR) de la feuille « recap_MAR »

sur la feuille « recap_RIN » aillant comme référence « SOGS » , jai une erreur « NA »

voici la formule que j’ai fait:

=RECHERCHEV(A2;recap_MAR!A2:B22;2;FAUX)

J’ai essayer de figer les cellules, même résultat.

J’ai excel 2010.

Merci de votre aide.

Nicolas

Bonjour Nico911,

Il est normal que vous ayez des #N/A :roll_eyes:
Vous cherchez des valeurs qui n’existent pas dans l’autre feuille

@+

Bonjour,
Teste avec cette formule en B2, à tirer vers le bas

=SIERREUR(RECHERCHEV("SOG"&A2;recap_MAR!$A$2:$B$22;2;FAUX);"")

Bonjour Mimimathy,

Je te remercie ça marche. Par contre je voudrais comprendre un peu.

Dans la formule tu mets "SOG" &A2, je voudrais comprendre pourquoi (les parenthèses et le &) et
SOG sans le (s); car dans l’intitulé c’est SOG. SOG sans (s) ça marche pas.

Merci beaucoup.

Bonne journée.

Bonjour NonoDu45.

Merci du retour.

Même quand j’essayais avec une cellule où il y avait une valeur ça me mettait NA.

Merci.

Bonne journée.

Nico911,

Quand Excel met #N/A c’est qu’il ne trouve pas la valeur dans sa recherche.
Donc même quand la valeur existe, c’est que l’une est du texte et l’autre est un nombre :wink:

1 J'aime

Re

L’intitulé n’a rien à voir
les cellules commencent par SOG que l’on place entre guillemet (c’est du texte) concaténé avec & et la valeur de la cellule
image

Re

Merci Mimimathy pour cette explication, j’ai compris.

Bonne journée.

Nicolas

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.