Planning à l’horizontal

Bonjour,
Je dois créer un planning à l’horizontale comme exemple ci-joint.
Comment faut-il faire pour que les cases soient remplies de manières automatiques (jour de la semaine) ?
Pouvez-vous m’expliquer car je dois réutiliser cette méthode dans mon travail ?

Planning divers.xlsx (8,5 Ko)

Bonjour Bounty

Selon le fichier donné :

En A2 tu mets =A1
En B2 tu mets = A2+1
Format de cellule → Personnalisée et tu mets « jj »
En A3, tu mets =INDEX({"L";"M";"M";"J";"V";"S";"D"};JOURSEM(A2;2))

En B3, tu mets =INDEX({"L";"M";"M";"J";"V";"S";"D"};JOURSEM(B2;2))

B2 et B3 recopie vers la droite d’autant de colonnes que tu souhaites

Pour l’affichage des mois,
en AF1, tu mets =SI(MOIS(AF2)<>MOIS(AE2);TEXTE(AF2;"mmm-aa");"")

Recopie vers la drotie

Ce qui donne ceci :wink:
Bounty_Planning divers.xlsx (11,2 Ko)

A+

1 J'aime

J’ai fait un test, pourquoi ça me donne ça ?

Bounty_Planning divers.xlsx (12,3 Ko)

Après une autre tentative ça fonctionne mais pour le mois de février comment faire lorsqu’il y a 29 jours dans le mois ?

Bonjour Bounty

Ce sera automatique :thinking: :stuck_out_tongue_winking_eye:

Mettez 01/01/2024 en A1 et vous verrez

A+

Merci beaucoup Nono pour votre aide

1 J'aime