PB formule recherchex

Bonjour,
j’ai un problème de résultat avec ma formule recherchex je vous joints 2 photos la première est mon tableau de synthèse avec la formule et la 2 ème et le tableau de recherche.

Si vous avez un peu de temps.
Merci de votre aide.

Bonjour,
Un fichier Excel nous aidera mieux a vous aider.
Cordialement

Bonjour.
Je réduis mon fichier et vous l’envoi.
Cordialement

1 « J'aime »

Voici le fichier
PB recherchex.xlsx (22,0 Ko)

1 « J'aime »

La fonction FILTRE sera appropriée,
Voici ce que vous pouvez mettre sur la cellule C3:

=FILTRE('Production OPTIQUE'!L:L;('Production OPTIQUE'!E:E=$B3)*('Production OPTIQUE'!G:G=C$2);"")

Vous pouvez après l’tirer sur toutes vos cellules. (bas, gauche)
PB recherchex.xlsx (30,5 Ko)

NB: Office 365
Cordialement

Ça ne fonctionne pas pour moi.
Voilà ce que ça me mets.

Quand je regarde sur le fichier renvoyer la formule commence par:
=_xlfn._xlws.FILTER(

Ah je vois, vous avez la version inferieur à Office 365
D’après votre menu, vous devriez avoir Office 2016 ou 2019 si je m’trompe pas.

Oui j’ai Office 2016

Ah, sur 2016 on n’a pas encore RECHERCHEX mais il existe une veille fonction qui pourra vous aider : INDEX et EQUIV.
Un instant je vais l’tester, et voila :
Une simple recherchev a fait l’affaire :

=SIERREUR(RECHERCHEV($B3&C$2;'Production OPTIQUE'!$H:$M;6;FAUX);"")

PB recherchex (1).xlsx (28,1 Ko)

Cordialement

Je suis désolé cela ne fonctionne pas pour moi. Et je comprends pas pourquoi le recherche se fait dans la plage H a M dans cette plage la il me trouvera pas les valeurs de B3 et C2? ça devrait pas plutôt être de E a L?

Désolé j’avais oublié. J’ai rajouté une nouvelle colonne dans ton fichier source:
PB recherchex (1).xlsx (28,1 Ko)
Cordialement

1 « J'aime »