Liste de validation avec condition

Test Remise de chèques.xls (38 Ko)

Bonjour à tous :slight_smile:

Dans le tableau ci-joint, 1er onglet, je voudrais svp en colonne B « Nom de l’émetteur » une liste de choix des clients qui soit limitée en fonction de la banque indiquée en colonne A.
Les données sont dans l’onglet BDD Clients

Merci de votre aide

Bonjour

Ci joint une proposition

Mes salutations

Test Remise de chèques.xls (39 Ko)

Bonjour Johnny,
Plutôt

=INDIRECT($A9)

sans figer la ligne, sinon, toutes les liste recopiées vers le bas auront les mêmes données

1 « J'aime »

Bonjour Mimi,

Ouuuuu oui merci
Dans ces paramètres je n’arrive toujours pas à me faire que Excel il fige automatiquement. :frowning:

Merci pour la proposition, j’ai vu le principe, je vais essayer de reprendre en laissant la structure de base, car j’ai besoin aussi d’aller chercher le code comptable du client en 3ème colonne. Donc reprendre des listes de clients par Banque à côté ça ne m’arrange pas

Test Remise de chèques.xls (38 Ko)

Voilà ma dernière version qui fonctionne bien, merci pour votre aide !
Bonne journée !

Hello,
dans ta colonne Compte2 avec un recherchV et un sierreur pour éviter les #N/A

=SIERREUR(RECHERCHEV(B9;'BDD Clients'!B:C;2;0);"")

Merci, j’avais amélioré ça avec un test :
=SI(B9<>«  »;RECHERCHEV(B9;‹ BDD Clients ›!B:C;2;0);«  »)

en fait ton « test » ne fais que dire si B9 est vide affiche vide, alors que le rechercheV n’afficherait rien, hormis un #N/A, si B9 est vide, d’où le sierreur qui affichera du vide si B9 et vide

1 « J'aime »