Imbrication de SI, avec des CHERCHE

Bonjour,
On va dire que je suis plutôt bon sur Excel. Mais là j’ai un problème.
Je dois chercher dans une colonne certaines valeurs (texte, chiffre, ou les deux) et si elles y sont, écrire quelques chose dans la cellule en face.

=SI(CHERCHE("235";C2);"Acier";
SI(CHERCHE("195";C2);"Acier";
SI(CHERCHE("275";C2);"Acier";
SI(CHERCHE("s2";C2);"Acier";
SI(CHERCHE("355";C2);"Acier";
SI(CHERCHE("335";C2);"Acier";
SI(CHERCHE("24CD4S";C2);"Acier";
SI(CHERCHE("P265D4S";C2);"Acier";
SI(CHERCHE("ACIER";C2);"Acier";
SI(CHERCHE("6060";C2);"Aluminium";
SI(CHERCHE("5754";C2);"Aluminium";
SI(CHERCHE("AU4G";C2);"Aluminium";
SI(CHERCHE("304L";C2);"Acier Inoxydable";
SI(CHERCHE("316L";C2);"Acier Inoxydable";
SI(CHERCHE("GR320";C2);"Acier Inoxydable";
"autre")))))))))))))))

Le problème, la valeur du premier SI est bon, mais pour tous les autres j’ai un problème de valeur, je ne sais pas trop quoi faire ?

Merci pour votre aide.
Gaëtan

Suivi de Commande MP _ oct 2019 à sept 2020 _ clean _ BARRE .xlsm (262,4 Ko)

Bonjour

Si la fonction « CHERCHE » ne trouve pas elle génère une erreur « #VALEUR! »
D’où tes résultats dont la première recherche est dans cette configuration
Il faut traiter dans tes formules ces éventualités avec la fonction « ESTERR » ainsi :

SI(ESTERR(CHERCHE(« 235 »;C2))=FAUX;« Acier »)

Qui ne mets « Acier » que si la fonction CHERCHE placée en amont n’est pas en erreur (CHERCHE(« 235 »;C2)) donc la fonction « ESTERR » est « FAUX » car il n’y a pas d’erreur dans la recherche celle-ci a été trouvée et donc de mettre la donnée prévu dans ce cas « Acier »

Toutes tes recherches doivent être construites ainsi

Ton fichier corrigé

Regardes et dis moi

Suivi de Commande MP _ oct 2019 à sept 2020 _ clean _ BARRE .xlsm (262,8 Ko)

Merci pour ton aide.
C’est exactement ce que je voulais.

Bonne journée.
Gaëtan

Merci pour ton retour
À bientôt peut être

1 J'aime