Gestion de touret Câble

Bonjour à tous,

j’essaie d’avoir un petit outil pour la gestion de mes tourets
touret.xls (86 Ko)
que je dois encore améliorer
principe sur la feuille entrée on encode la date le numéro le type le nombre de m le type de projet…
dans ma feuille sortie j’aimerais qu’il tienne a jour en fonction de ce que je retire comme câble
en fonction des dates
ex si je retire du fibre 42 le 02/02(50m) et le 05/02 (10m)qu’il déduise tout de mes 500 m soit 440 restant
merci de votre aide

Bonjour sidec,

Il faut utiliser la fonction SOMME.SI.ENS()
Voir l’aide Excel ou Internet pour la fonction

@+

Bonsoir sidec, NonoDu45,

A tester =RECHERCHEV(C6;'Entrée touret'!C:G;3;FAUX)-SOMME.SI($D$6:D6;D6;$E$6:E6)

Quelle est ta version d’excel ?

Cordialement.

bonjour

version 2106

Bonjour,

Quand je dis version, je veux dire, Excel 2007, 2010, 2013, 2016, 2019 ou 365.
A propos d’office identifier la version d’office que j’utilise
Cordialement.

Re office Proffesionnel plus 2019
Cdlt
Stéphane

re,
Ok, un essai plus élaboré. A tester
Est il normal que deux tourets est le même numéro ?
Cordialement.
touret.xlsm (56,0 Ko)

Edit :
Version optimisée.
Pour afficher ou masquer les onglets, clic sur Gestion des tourets
Pour protéger ou déprotéger la feuille Gestion des tourets, double clic sur A1
Teste et fais moi un retour.
Cordialement.
sidec.xlsm (64,3 Ko)

top ,ca va bien m’aider :slight_smile:
peut-on mettre une alerte dans la feuille Gestion Touret quand il reste 25 m:ex attention pour le touret '‹ 554YCFFR › type ‹  › Fibre 42 ‹  › il reste 25 m
entrée touret et encodage nvx touret pour moi est la même chose ,il se retrouve deux fois…3
par contre dans sortie touret si on peux rajouter trois cases a cocher retourner par transport interne,retourner par transport externe, repris par client

cdt
Stéphane

re,
Non, la question est est ce que il peut y avoir deux tourets avec le même n° ?
Dans ton fichier initial ligne 6 et 7. Même n° mais type différent.
Cordialement.

re,

Cordialement

Edit :

sidec.xlsm (69,4 Ko)

Merci
possible d’afficher plusieurs seuils alertes ??la il n’en affiche que un
salutations Stéphane

Bonjour,
Version modifiée pour gérer le stock si plusieurs tourets avec le même numéro et le même type.

L’ActiveWorkbook.RefreshAll ne semble pas bien fonctionner, je ne sais pas pourquoi.
Pour mettre à jour le tableau des alertes, un clic à l’intérieur du tableau le mettra à jour.
Cordialement.
sidec.xlsm (74,8 Ko)

re,
Je viens de tester, il n’est pas possible d’avoir un même numéro de touret avec 2 types différents. Cela ne fonctionne pas dans la liste de choix de sortie de câble. Est ce un problème ?

L’actualisation de la liste d’alerte devrait fonctionner. Le clic à l’intérieur du tableau est toujours valide.

Cordialement.
sidec.xlsm (70,8 Ko)

Bonjour,
Pas de retour ?
Cordialement.

hello,
un grand merci
je le fais tester par les collègues et je reviens vers vous
bonne soirée