Comment ne pas tenir compte des cellules vides dans une moyenne

Bonjour,
j’aimerais savoir s’il y a une configuration type pour à effectuer pour qu’excel ne compte pas les cellules vides dans une moyenne.
Merci d’avance.

Bonjour,
Cellule vide, ou contenant 0 ou vide avec formule ??

Même si mathématiquement il est incorrect d’exclure les zéros d’une moyenne voici 3 formules:
Standard =SOMME(A1:A8)/(NB(A1:A8)-NB.SI(A1:A8;"=0"))
Matricielle {=MOYENNE(SI(A1:A8<>0;A1:A8))}
Excel2007 ou après =MOYENNE.SI(A1:A8;"<>0")

merci.
Il s’agit de faire une moyenne pour chaque élève certains n’ayant pas de notes pour certaines matières.essai moyene 1C1S+(1SEM).xlsx (18,4 Ko)
merci d’avance

Re,
Avec un SIERREUR() devant
essai moyene 1C1S+(1SEM).xlsx (25,6 Ko)

Par contre la moyenne des moyennes c’est une fausse moyenne
il faut reprendre toutes les cellules sauf les moyennes et cele sera plus juste
ex:
11,33 pour la ligne 2 alors que la moyenne des moyennes 9.73 :stuck_out_tongue_winking_eye:

image