Calcul nombre caractère

Bonjour,
J’ai un fichier Excel avec une colonne Id et dedans il y a des chiffres ou numéros et je souhaiterai avoir une formule pour ajouter un 0 si il y a un seulement un caractère dans la colonne ?

Merci d’avance,
Q

BAT_ID
BC
BC
BC
A
A
A
D
D
D

Forum excel

forum_excel.xlsx (130,1 Ko)
Voici un fichier d’exemple

J’ai peur de ne pas comprendre, tu veux faire quoi ?
rajouter un 0 au caractère si seulement un caractère dans la cellule ?

Oui c’est exactement ca !

Bonjour queneau, taz067, le forum,

Par formule en B1, ajoutez =SI(NBCAR(A1)=1;A1&« 0 »;A1) et tirez vers le bas.

Cordialement.

AL 22

1 « J'aime »

Bonjour @AL22, merci beaucoup !