Calcul avec différent critères

Bonjour à tous dans un premier temps, je désire qu’un modérateur supprime mon précédent message intitulé « Aide sur une formule de calcul sur ligne impair ou pair » car j’ai omis d’y insérer mon fichier et le replacer par celui-ci.

Dans la cellule Q535, le calcule doit être faire de S7 à S533 en recherchant les critères 1, 1 exa, 1 rec, 1 rep et 1 rec-rep dont le résultat doit seulement prendre en considération les périodes du AM d’une durée de 2h30 et dans R535, ce calcule doit aussi considérer les périodes du PM dont elles sont d’une durée de 3 heures.

Je ne sais vraiment pas comment m’y prendre. Je joins mon fichier et j
Horaire esthétique 2024-2025_MAJ_03-07-2024.xlsx (1,7 Mo)
e vous remercie de l’aide que vous pourrez me donner.

Hello
pourquoi refaire une demande il suffisait de rajouter le fichier sur la demande precedente…

Voila formule mise a jour en Q536 et R536
Horaire esthétique 2024-2025_MAJ_03-07-2024.xlsx (1,7 Mo)

Capture d'écran 2024-07-09 134914
et voilà la formule utilisée

=NB.SI.ENS($P$7:$P$533;$BH$5;$S$7:$S$533;"1")+N("La ref cellule $BH$5 est celle pour la période A.M. (2H30)")+
NB.SI.ENS($P$7:$P$533;$BH$5;$S$7:$S$533;"1 exa")+
NB.SI.ENS($P$7:$P$533;$BH$5;$S$7:$S$533;"1 rec")+
NB.SI.ENS($P$7:$P$533;$BH$5;$S$7:$S$533;"1 rep")+
NB.SI.ENS($P$7:$P$533;$BH$5;$S$7:$S$533;"1 rec-rep")+

Pour info, la fonction N n’est pas prise en compte pour les calculs, celle-ci étant utilisée pour mettre des commentaires.

Attention pour les prochaines mise en forme dans ta colonne P pour les périodes A.M. (2h30) ou P.M. (3h) il faut qu’elles restent cohérentes avec la formule, j’ai vu que sur d’autre colonne, tu ne mettais que AM ou PM

Wow super ça fonctionne. Je te remercie énormément. Je prend également en note tes commentaires en considération. Merci!

@Mamanpouli
Horaire esthétique 2024-2025_MAJ_03-07-2024.xlsx (1,7 Mo)
j’ai fait la mise a jour des formules de Q536 à R555

1 « J'aime »

J’apprécie énormément votre aide il est très instructif. Il me reste un problème à résoudre dans ce fichier et je vais essayer d’être la plus clair possible afin de vous identifier mon problème.

En O572, la formule a recherchée les cellules contenant : 14, 14 exa, 14 rec, 14 rep et 14 rec-rep et il y a vraiment 40 cellules au total. Dans cette même cellule, il faudra que la somme des cellules considère la somme des périodes de 2.50 en AM à L.L. en référence à O558 et somme des périodes de 3.00 en PM à L.L. qui devrait donner des heures totales de 105.5 heures car c’est le seul module qui appartient à cette personne dans ce groupe. J’ai tenté plusieurs calcul mais j’y arrive pas. C’est tellement plus facile lorsque les périodes du AM et du PM sont de 3 heures mais très complexe dans cet exemple. Je joins mon fichier.
Horaire esthétique 2024-2025_MAJ_03-09-2024.xlsx (1,8 Mo)

Je regarde quand je rentre chez moi

voila avec des explications dans la formule en O572 toujours avec la fonction
+N("explication entre guillemets qui n'est pas pris en compte dans le calcul")
Horaire esthétique 2024-2025_MAJ_03-09-2024.xlsx (1,7 Mo)

Capture d'écran 2024-07-10 162027

Un grand merci pour ton expertise je l’apprécie grandement tout est ok.