Automatisation en fonction d'un tableau de données

Bonjour,

Je souhaites créer un tableau de suivi en automatisant le remplissage du tableau d’un onglet par rapport au tableau de données d’un second onglet.

Je vous joins une photo sur laquelle j’ai simulé mon besoin en indiquant dans l’onglet « Feuil1 » un « Oui » (C2) sur la ligne 2 avec l’indicateur « 111 » (A2) puisque le tableau de l’onglet « Feuil2 » indique sur la ligne 3 avec l’indicateur « 111 » (A3) correspondant qu’il s’agit d’une « Femme » (B3).

Tableau de données :

Tableau de suivi :

Pour formaliser mon besoin, la formule de la case « C2 » de la « Feuil1 » devrait dire :
=Si A2 est égal à une des valeur de la colonne A de l’onglet « Feuil2 » et que la valeur de la case B? de la ligne correspondante est « Femme » alors C2 est égal à « Oui »

=SI(ET(NB.SI(‹ Feuil2 ›!A:A;A2);???); « Oui »)

Auriez-vous une formule pour cela svp ?

Merci par avance.

Bonjour,

Il me semble que la formule pourrait être
`=si(RECHERCHEV(A2;Feuil2!$A$2:$B$100;2;faux)=« Femme »;« Oui »;"")

Bonjour le Fil,

@ouisansdoute Il faut prendre en compte chaque colonne :wink:

Comme ceci : =SI(RECHERCHEV($A2;Feuil2!$A$1:$B$3;2;FAUX)=B$1;« Oui »;"")

Voici le fichier
Jacque93_240421.xlsx (9,6 Ko)

@+

Merci beaucoup ouisansdoute & NonoDu45 ! :slight_smile:
C’est parfait !!