Valeur SI imbriquée combinée à une RECHERCHE

Je suis nouveau sur le Forum et je vous salut à tous.

Voici ma problématique:

Je conçois un devis qui doit prendre en compte les différents codes de TVA (1=20%, 2=5,5%, 3=0%) afin d’obtenir la valeur des différentes TVA.

J’ai donc 3 colonnes (déjà renseignées) :

  • Colonne 1 nommée codetva= mes codes TVA 1, 2 ou 3
  • Colonne 2 nommée colonneht = mon total HT, résultat à la ligne
  • Colonne 3 nommée colonnettc = mon total TTC, résultat à la ligne

Problème : Si dans la colonne 1 codetva je trouve le code 1, alors j’additionne le total de ma colonne 2 colonnettc moins le total de ma colonne 3 colonneht (je devrais obtenir la valeur de la TVA 1… normalement).

Idem pour la TVA 2 et la TVA 3.

Voici ce que j’ai essayé mais je pense qu’il faut y inclure une recherche :

=SI(codetva=1;SOMME(colonnettc)-SOMME(colonneht);
SI(codetva=2;SOMME(colonnettc)-SOMME(colonneht);
SI(codetva=3;SOMME(colonnettc)-SOMME(colonneht);0)))

Pas de VBA s’il vous plait, mon classeur doit rester en Excel 2010 .xlsx

Merci pour votre aide.

Bonjour,

Peux-tu avoir plusieurs lignes dans tes colonnes ?
Formule pour calculer le montant de la TVA sur chaque ligne :
=SI(A2=1;B2*20%;SI(A2=2;B*5,5%;SI(A2=3;0)))
Le calcul total de la TVA est la somme des TVA…

Pour extraire la TVA en une seule fois :
=(SOMME.SI(A2:A100;1;B2:B100)*20%)+(SOMME.SI(A2:A100;2;B2:B100)*5,5%)
Explication :
SOMME.SI(A2:A100;1;B2:B100)*20% => fait la somme des lignes ayant un code TVA =1 et multiplie par 20%
(SOMME.SI(A2:A100;2;B2:B100)*5,5%) => fait la somme des lignes ayant un code TVA =2 et multiplie par 5,5%
Pas de somme si le code est 3 car le taux est de 0% donc, toujours égal à 0.

Bonjour [ouisansdoute],

Merci pour les solutions apportées à mon problème.

Bonne journée.

François