Transformer une cellule nombre en texte

Bonjour,
si quelqu’un peut m’aider… ça serait super !

Je dois transformer à peu près 1000 lignes de chiffres de 13 caractères en format “nombre” pour un format “texte” afin de réaliser un import qui ne fonctionne pas.

J’ai essayé la fonction =texte(cellule;format texte) mais ça ne fonctionne pas car le chiffre se transforme en texte mais au lieu de 1234567891234 il apparait 123456+12. ce qui est très problématique.

Merci pour votre aideYOLOMATRIX Ergobaby.xlsx (68,8 Ko)

Bonjour,
Tu fait =ta cellule et tu changes le format de la cellule en NOMBRE au lieu de STANDARD sans chiffres après la virgule

Bonjour Mimimathy, ça ne fonctionne pas. quand je fais =ma cellule et que je modifie auparavant la cellule en nombre au lieu de standard.
il n’y a pas de chiffres après la virgule sur mon nombre.
L’objectif est d’enregistrer mon fichier en format CSV pour pouvoir faire l’import de ma base de donnée.

place ton fichier dans le post
image

C’est bon je viens de joindre le fichier il s’agit de la colonne V “EAN”
d’autre part j’ai un autre soucis sur ce fichier j’ai des colonnes avec des virgules “,” et il faudrait que je transforme tout en points “.” sinon ça foire l’import du fichier. j’ai utilisé la fonction ctrl + f mais ça fonctionne pas, je dois pas bien comprendre… désolé suis pas au top avec Excel.

Bonjour remi,
Pour mettre d’office un point ou une virgule c’est un choix dans les options d’Excel, Options avancées, utiliser les séparateurs système (ceux de Windows par défaut), ou choisir soi même son séparateur décimal ."," ou “.”
ensuite dans ton fichier regarde la feuille 1 qui est une copie de l’originale, la valeur de la colonne “V” est en format texte (ABC) et plus en nombre…!
cordialement

je joint le fichier modifiéYOLOMATRIX Ergobaby V2.xlsx (121,6 Ko) , désolé

Helllo lucky,

merci pour ta réponse. par contre comment t’as fait pour modifier la colonne V: ? :))))

Bonne fin de journée

Re, j’ai tout d’abord créé une nouvelle feuille par le biais de “Déplacer ou copier”. Ensuite dans cette feuille, pour ne pas modifier l’original, j’ai inséré une nouvelle colonne que j’ai immédiatement mis en format “Texte”. Dans ce cas, vérifier si le format Texte propose “ABC” suivi des chiffres et non du format scientifique. Ensuite il a suffit de recopier seulement les valeurs, sans format, de l’ancienne colonne.
Cordialement

Hello Luc,
Je vais avoir 2 questions car ce n’est pas encore au point…
1- comment tu fais pour : " vérifier si le format Texte propose “ABC” suivi des chiffres et non du format scientifique" … je ne sais pas faire… désolé suis novice en Excel
2- quand je prends ton fichier et que je le transforme en CSV il remet la colonne V: avec la série de chiffre + 12 exemple. donc au moment de mon import dans mon système la recopie ne va pas être bonne. je t’ai mis le fichier CSV en PJ pour que tu puisse voir de quoi je parle.
Cordialement
YOLOMATRIX Ergobaby V2 (2).csv (71,9 Ko)

Hello,
Pour ta réponse, idem je ne sais pas ou se trouve les “options avancées” sur Excel pour que je puisse choisir mon séparateur “.” au lieu de “,”. Je possède Excel 2007 si ça peut aider.

Bonjour remi,
un petit lien explicatif sur les options d’Excel. (https://www.youtube.com/watch?v=COkf7_fBQVc)

cordialement,

1 J'aime

Re,
En ce qui concerne le fichier CSV, pour le contrôler, il suffit de l’ouvrir avec le Bloc-Note,(séparateur point-virgule) et là tu verras que le nombre est en entier, donc ton import doit fonctionner. il ne faut surtout pas ré ouvrir ce CSV avec Excel…
Cordialement

1 J'aime

Luc, et pour ça ?
1- comment tu fais pour : " vérifier si le format Texte propose “ABC” suivi des chiffres et non du format scientifique" … je ne sais pas faire… désolé suis novice en Excel

Cdt

Re,
Il me semble que c’est ton classeur qui a été mal complété. En effet, dans les colonnes où l’on est sûr qu’il n’y aura que du texte, il faut la mettre en format texte avant de saisir quoi que ce soit. ensuite il faut remplir les cellules avec des chiffres et ils apparaissent en totalité avec la note que le chiffre à été saisi en format texte. C’est pour cela que j’ai inséré une colonne vierge, mise en format texte, et retapé les chiffres.

ah ok donc ça redemande de retaper tous les chiffres à la main quand même… c’est ce que je voulais éviter.
Merci pour toutes ces réponses en tous les cas.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.