Somme VBA Excel

Bonjour
Je souhaite faire la somme de ma plage (A4 : jusqu’à la dernière ligne)
J’ai essayé le code suivant

Sub SommeDebit()
    Set Tdebit = Range("A4").End(xlDown)
    Tdebit.Offset(2, 0).FormulaR1C1 = "=SUM(A4:Tdebit)"
End Sub

Mais résultat est #NOM?

MerciCapture

Bonjour,
Mettre cette formule sur la cellule qui donne la somme

=SOMME(A1:DECALER(A15;-1;0))

Ici, A15 est la cellule qui aura la somme

Merci Mr @Mimimathy

mais comment transforme cette fonction en VBA

Sub SommeDebit()
Set Tdebit = Range(“A4”).End(xlDown)
Tdebit.Offset(2, 0).Formula = “=SUM(A4: offset(Tdebit.offset(1,0);-1;0))”
End Sub

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.