Somme de cellules dont le contenu est conditionné


#1

Bonjour,
Je vous explique la situation : j’ai une liste d’invités pour une réception, et je voudrais calculer le nombre total des invités.
Or, dans ma colonne à additionner, j’ai conditionné le nombre d’invités en fonction du fait qu’il y ait un conjoint ou non :
si dans la colonne conjoint il y a “et Madame” “et Monsieur” alors il faut indiquer dans la colonne nombre 2, si il n’y a rien, il faut indiquer 1

=SI(I829=“et Madame”; “2”;SI(I829=“et Monsieur”; “2”; SI(I829=""; “1”)))

Quand j’essaye de faire la somme de la colonne nombre, j’ai l’impression que le logiciel considère que c’est du texte et ne prend donc pas en compte le chiffre indiqué in fine.
Que faire ?
Merci d’avance de votre aide,


#2

Bonjour @doxchou,

Ta formule fonctionne, mais effectivement elle te donne un résultat au format texte puisque tu as mis entre guillemets les “2” et “1”.

Je te propose de simplifier ta formule en utilisant la fonction “OU” et donc cela donnerait ceci:

=SI(OU(I829="et Madame";I829="et Monsieur");2;1)

Cordialement.


#3

Super, merci beaucoup ça fonctionne parfaitement :slight_smile:
Bonne journée!