Somme à partir d'une variable et d'une date

Bonjour,
j’aimerai savoir s’il est possible de réaliser ma demande suivante:

Présentation du tableau:
Colonne A: Nom
Colonne B: Date
Colonne C: Produits
Colonne D: QTE
Colonne E: Prix unitaire
Colonne F: total (D*E)
Colonne G: total de la commande

Dans la colonne G, j’aimerai afficher le total de la Commande de client1 (je n’ai pas de base de donnée, je connais le nom du client que lorsqu’il me passe une commande) à la date du 01/01/2019 pour les produits:
Pantalon QTE 2 prix unitaire 40€ (Total en colonne F à 80 €)
Chemise QTE 1 prix unitaire 30€ (Total en colonne F à 30 €)
Chaussette QTE 3 prix unitaire 4€ (Total en colonne F à 12 €)
Donc on va dire C2=pantalon,C3=chemise et C4=chaussette , et si possible que le total de la commande ne s’affiche que en G2 ( que G3,G4 reste vide, mais si en A5 j’ai client2, il me recommence la formule automatiquement pour mettre un total à G5)

Bonsoir Justmy987,

Je pense qu’il est possible de répondre à votre question.
Il faut se pencher en premier lieu à faire la somme selon le nom du client et selon la date. Pour cela on peut utiliser la fonction somme.si.ens.

Ensuite, pour laisser le total sur la 1ere ligne, je teste si les cellules nom et date au-dessus sont identiques. Si oui, on laisse vide … autrement, on fait le total.

Voici la formule :

=SI(ET((A2=A1);(B2=B1));"";SOMME.SI.ENS(F:F;A:A;A2;B:B;B2))

Il faudrait tester avec des valeurs réelles.

C’est ce qu’il vous faut ?

Bonne soirée

Lunosomme si avec date et variable.xlsx (10,8 Ko)

Bonjour,
Oui ça marche j’ai testé plus tôt dans l’après midi, je vous remercie pour votre retour, vous êtes top :slight_smile:

1 J'aime

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.