Solde Débit et Crédit

Bonsoir Mimimathy & mdo100
Vraiment ça fait plaisir de vous lire; voila j’ai posé cette question dans un forum,ou il y a des gents comme vous très poli, mais on m a répondu que la formule que j’ai dans mon fichier, elle est bonne.
Je sais que c’est la vérité,mais je veux approfondir mes connaissances en VBA je veux savoir
s’il vous plais comment dire en VBA :
=SI(A3="";"";SI(SOMME($F$2;$C$3:$C3)-SOMME($D$3:$D3)>0;SOMME($F$2;$C$3:$C3)-SOMME($D$3:$D3);""))
=SI(A4="";"";SI(SOMME($F$2;$C$3:$C4)-SOMME($D$3:$D4)<0;(SOMME($F$2;$C$3:$C4)-SOMME($D$3:$D4))*-1;""))
car j’ai essayé et le code me donne erreur

Merci a vous Tous.
ci joint mon fichier comme modele.Exercice_SoldeNegatif.xlsx (19,0 Ko)

Bonjour,
Je ne vois guère d’intérêt vu que tu travailles sur un tableau, mais juste pour le “FUN”

Teste ceci

Exercice_SoldeNegatif.xlsm (17,6 Ko)

Bonjour Mimimathy

Vraiment c’est très Coule, mais j’étais très loin de la solution, Merci encore Mimimathy
j’apprends beaucoup dans ce forum, et merci du temps que tu consacre pour les débutants comme moi, et je n’oublie pas de saluer notre ami mdo100
Très bonne journée a vous tous.

Merci

1 J'aime

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.