Remplissage automatique avec plusieurs feuilles

Bonjour

Je cherche une solution depuis quelques jours deja mais je ne trouve pas ma reponse.

Je voudrais faire une facture d’après plusieurs feuilles.
Sur la feuille 1 (facture) je voudrais juste à avoir à rentrer le code client A ou B ou C etc …pour que les articles soit rempli automatiquement.
J’ai mis un exemple dans mon fichier ci joint

Sans nom 1.xls (8,5 Ko)

merci de votre aide :slight_smile:

Bonjour,
Avec la fonction indirect qui cherche par rapport au nom de l’onglet

=INDIRECT("’"&“Client “&$C$4&”’!c4”)

Sans nom 1.xls (22 Ko)

Merci pour la rapidité de la réponse.

Avec le nouveau tableau que je viens de mettre, la fonction indirect marche t’elle aussi ?
Comme dans le 1er je cherche à rentrer uniquement mon "code client " en feuille 1 et qu’il me trouve les quantité des articles 1 , 2 et 3

Merci beaucoup

Sans nom 2.xls (9,5 Ko)

Bonjour @Drakki,
Salut @Mimimathy, :wink:

Avec le dernier fichier joint, voici une proposition:

Comme il n’y a pas le même nombre de ligne dans les feuilles “40101 & 40102”, je te propose de faire la somme des ses 2 feuilles en ligne 2.

Capture1

Puis de créer une liste déroulante dans la feuille “Facture” en cellule “B2”.

Enfin en “B7”

=SIERREUR(INDEX(INDIRECT($B$2&"!B2:d2");EQUIV($A7;INDIRECT($B$2&"!B1:d1");0));"")

Tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> Drakki V1.xlsx (14,3 Ko)

Cordialement.

1 J'aime

Super genial

Merci pour votre aide :wink:

Re @Drakki, @Mimimathy,

J’ai une proposition différente de celle @Mimimathy ( qui ne m’en voudra pas je l’espère :wink: ) concernant le premier fichier.

Même punition pour créer une liste en “C4” de la feuille “Facture”.

Puis en “C6” de la feuille “Facture”.

=INDIRECT(ADRESSE(LIGNES($1:4);COLONNES($A:C);;;"Client "&$C$4))

Tirer vers la droite et vers le bas.

Ton fichier en retour ICI==> Drakki V2.xlsx (13,2 Ko)

Bonne soirée.
Cordialement.

PS: Si ton problème est résolu: