#REF! si le second fichier n'est pas ouvert

Bonjour,

J’ai 2 fichiers ouverts actuellement et les deux ont un format tableau appliqué aux données. J’essaie de faire une Recherchev() des données du fichier #2 et tout fonctionne bien. Excel m’insère le nom du fichier avec le nom de la table et de la colonne que je recherche. Ça fonctionne.

=RECHERCHEV([@Code];‘C:\Users\a.goudreau\Desktop\Test1.xlsx’!Tableau1[#Données];3;FAUX)

Cependant, lorsque je ferme et rouvre mon fichier avec ma formule et sans ouvrir le 2e fichier avec les données, on dirait qu’il ne reconnait plus ma formule et n’est pas capable de lire dans le fichier source…

Il me donne des #REF! et je ne suis plus capable de faire le lien avec mon 2e fichier où se trouve mes données à récupérer.

Est-ce que vous savez où est mon problème ? Est-ce le format de tableau qui cause problème, car si j’utilise les adresses du genre A1:G99, mes formules sont correctes et le lien est bien conservé sans que je sois obligé d’ouvrir le fichier source. Est-ce qu’il y a un moyen de faire spécial avec les références à un format de tableau que je ne connais pas ?

Merci.

En espérant que c’est clair…

Alain Goudreau
Conseiller SIG – Analyse solutions d’affaires et assurance qualité TI
Service Innovation & Technologies
Téléphone : 450 978-6888, poste 4348
http://www.laval.cahttp://www.laval.ca/
[2017-07-11 11_55_20-LogoLaval_4coul]

Bonjour,

Pour régler le problème, il faut, dans le classeur contenant les formules, depuis le menu DONNEES / CONNEXIONS / Modifier les liens.
et en cliquant sur Invite de démarrage, cocher
“Ne pas afficher l’alerte et ne pas mettre à jour les liens automatiques”

La formule sera toujours là mais les données se mettront à jour qu’à l’ouverture du classeur contenant les données

2 J'aimes

Merci beaucoup pour la réponse. Je vais essayer cela.

Bonne journée,

Alain Goudreau
Conseiller SIG – Analyse solutions d’affaires et assurance qualité TI
Service Innovation & Technologies
Téléphone : 450 978-6888, poste 4348
http://www.laval.cahttp://www.laval.ca/
[2017-07-11 11_55_20-LogoLaval_4coul]