RECHERCHEV avec conditions

Bonjour,

Je suis bloquée sur 2 de mes formules :

  • Tout d’abord je souhaite obtenir le solde d’un compte qui se situe dans une autre feuille. Ce solde peut se situer dans une colonne de débit ou de crédit.

  • Puis je souhaite qu’une annotation s’affiche automatiquement si les soldes coïncident avec une 3ème feuille

formule BG.xlsx (22,8 Ko)

Merci d’avance pour votre aide.

Bonne soirée

Re ,

Bonsoir JELO

Voila j’ais essayé de faire ce que vous demandez si toute fois j’ais bien compris votre énoncé

je vous renvois votre fichier avec les changements en espérant que c’la vous convienne formule BG.xlsx (27,6 Ko)

Cordialement

kiss6

1 J'aime

Bonjour à tous
Bonjour Kiss6

pour info, la formule pour la colonne B pet être réduit:

=SI(RECHERCHEV(A1;BG!$B$3:$G$163;6;0)<>"";RECHERCHEV(A1;BG!$B$3:$G$163;6;0);RECHERCHEV(A1;BG!$B$3:$G$163;7;0))

Cela évite les #VALEUR!

et pour la colonne C, rajouter simplement un SIERREUR, et placer un OU pour ne pas imbriquer deux SI

=SIERREUR(SI(OU(B1=analyse!$E$11;B1=analyse!$F$11);"OK !";"NO OK !");"")
1 J'aime

Bonjour,

Un grand merci à vous kiss6 et mimimathy.

Cependant, la formule principale rencontre encore un problème.
En effet, seul les soldes créditeurs (colonne G de la feuille BG) sont pris en comptes. Par conséquent, si un solde est débiteur (colonne F de la feuille BG), il ne s’affiche pas dans la feuille formule…

Savez vous comment y remédier ?

Bien cordialement

Re,
Je n’avais pas regarder le résultat sur le classeur de Kiss6

formule BG.xlsx (25,6 Ko)

en B2

=SOMME(DECALER(BG!$B$3;EQUIV(A1;BG!$B$3:$B$163;0)-1;4;1;2))

en C2

=SIERREUR(SI(OU(B1=analyse!$E$11;B1=analyse!$F$11);"OK !";"NO OK !");"")

Bonjour a tous

Bonjour Mimimathy

Merci a vous d’avoir corrigé l’erreur j’avais pensé a “sierreur” mais pas “ou” mais c’la tout de même

contribué a la demande de Jelo merci a vous

Cordialement

kiss6

Super, ça fonctionne !!! MERCI bcp

1 J'aime