Recherche multicritère

Bonjour,

présentement j’utilise cette valeur pour afficher mes résultats.

=SIERREUR(INDEX(Table[Formation],PETITE.VALEUR(SI($E$5=Table[Liste de(s) poste(s)],LIGNE(Table[Liste de(s) poste(s)])-MIN(LIGNE(TableMaitresse!$B$3))+1,""),LIGNES(E$7:E7))),"")

Le résultas s’affiche un a la suite de l’autre

j’aimerais utiliser ce resultats pour effecture une autre recherche dans d’autre colonne

Rechercher E2 ( feuille Tri ) dans le tableau ( feuille Table )

verifier dans les colones employé si il y a une valeur

si oui afficher le nom et passer a la colone suivante.

Plan de formation.xlsx (88,8 Ko)

voici le fichier

merci de votre aide.

Bonjour,

Une formule à mettre en G7, et à tirer vers le bas

=SIERREUR(INDEX(Tableau;1;EQUIV("X";INDEX(Tableau;EQUIV(E7;INDEX(Tableau;;4);0););0));"")

Plan de formation.xlsx (89,2 Ko)

Bonjour,

merci de votre réponse, mais cela n’affiche qu’une colonne et avec (nom répétitifs)

y a-t-il moyen d’avoir une seul fois le nom et d’avoir toute les colonnes si la valeur est vrai “X” ?

Re,

Au vue des explications, place un classeur exemple avec ce que tu voudrais voir, au moins c’est plus compréhensible

voir Réf en vert dans le tableau et résultats rechercher en jaune

Plan de formation.xlsx (88,8 Ko)

Bonjour,

A tester
Plan de formation (1).xlsx (89,0 Ko)

Bonjour,

j’ai tester la nouvelle formule, mais celle ci ne fonctionne pas bien.
lorsque je change le poste celle E5 ci indique des # d’employés non formé

je me suis peut-etre mal exprimé, voici ce que je cherche a produire

#1 Rechercher La 1 iere ligne qui correspond a E5 “vert” dans le tableau
#2 Verifier dans les Colonnes I a R si la ligne est vrai “x”
#3 Donner en ordre les resultats “jaune”

Plan de formation.xlsx (138,6 Ko)

Bonjour,

Un test avec une macro qui affiche le nom des employés si il a croix (ou autres) sur changement du déroulant en cellule E5
Plan de formation.xlsm (149,2 Ko)

Bonjour,

cest exactement ce que je recherche.

merci de votre aide

1 J'aime

Re,

Il suffit de bien expliquer dés le départ avec des exemples CONCRETS :wink:

Si le problème est résolu, n’oublie pas de passer le post en résolu :wink:

Bonjour,

#1 Rechercher La 1 iere ligne qui correspond a E5 “vert” dans le tableau
#2 Verifier dans les Colonnes I a R si la ligne est vrai “x”
#3 Donner en ordre les resultats “jaune”

est-ce possible de modifier la formule pour rechercher toutes les lignes qui correspond a E5 ?

Plan de formation.xlsm (149,1 Ko)

Voir fichier joint, manque employé #4 & #5 dans la liste BEA et #4 formation implant

Bonjour

A tester
Plan de formation (1).xlsm (149,4 Ko)

merci, cela règle le fais d’avoir la même formation sur différent poste.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.