Recherche de cellule et modifier la cellule 3 colonnes à gche

Bonjour, je suis un peu novice.

J’aimerai faire une recherche dans une feuille chaque mot Tc99m et modifier pour chaque cellule contenant ce mot, la valeur de la 3ème colonne à gche de cette cellule qui contient ce mot, par le chiffre 0.2

Ex. si dans ma colonne I j’ai la ligne 313-318 et 320 avec ce mot, je voudrai que dans la colonne F, ces 3 lignes aient la valeur 0.2

Merci de votre aide.

Bonjour palain,
S’il te plaît, envoyez un fichier excel pour nous permettre de te répondre le mieux.
Cordialement!

Bonjour @palain, @panda,

@palain, si en “I313” = Tc99m, alors essai cette formule:

En “F313”

=SUBSTITUE(I313;"Tc99m";0,2)

A recopier vers le haut et / ou vers le bas autant que nécessaire.

Cordialement.

Merci, mais il peut s’agir de la présence de cette valeur de manière aléatoire.

Il doit donc faire une recherche et SI il trouve, alors modifier 2 colonnes à gche la valeur… je mets le fichier d’exemple dans le message suivant. Merci

TEST.xlsx (21,9 Ko)

Re @palain,

Si tu acceptes une colonne supplémentaire en “G”, alors:

En “G2”

=SI(J2="TC99M";SUBSTITUE(J2;"TC99M";0,2)*1;F2)

=SI(J2="TC99M";0,2;F2)

Fichier de retour ICI==> palain TEST.xlsx (26,8 Ko)

Cdlt.

Re @palain,

Une autre proposition par macro VBA:

Sub Test()
 
    Dim Plage As Range
    Dim Cel As Range
    Dim Lgn As Long
 
    With ActiveSheet 'Feuille active
        'A partir de la ligne 2, colonne I jusqu'à la dernère ligne
        Set Plage = .Range(.Cells(2, 9), .Cells(.Rows.Count, 1).End(xlUp))
 
    End With
 
    For Each Cel In Plage
        'Si dans la plage colonne I on trouve TC99M, alors on remplace dans la colonne F
        If Cel.Value = "TC99M" Then Cel.Offset(, -3).Value = 0.2
 
    Next Cel
 
End Sub

Appuyer sur le bouton “Test” et les valeurs de la colonne “F” seront remplacées par 0,2 si on trouve TC99M en face colonne “I” sinon on laisse les valeurs.

palain TEST.xlsm (30,5 Ko)

Cdlt.

1 J'aime

Excellent !!!

Merci mdo100 et belle journée

Bonjour

Si ton problème est résolu, peux-tu stp cocher le petit :white_check_mark: sous le message qui contient la solution stp?

Cela nous aide à déterminer qui a encore besoin d’aide et qui est sauvé!

Merci

1 J'aime