Plusieurs conditions avec la fonction SI + Texte

Bonjour tout le monde,

J’essaye de combiner 2 tests (Masculin ou Féminin) avec plusieurs tests tout dépend du sexe. Par ex. si c’est ‹ ‹ Masculin › › et la valeur : 2<G14<5 alors afficher ‹ ‹ Gras essentiel min › ›, par contre si c’est ‹ ‹ Féminin › › et la valeur est : 2<G14<5 alors afficher ‹ ‹ Gras essentiel min › › ainsi de suite pour le reste des autres tests.

La formule suivante fonctionne juste lorsque je sélectionne Masculin, mais il m’affiche FAUX lorsque je choisis Féminin ???

=SI(G10=« Masculin »;SI(ET(G14>2;G14<5);« Gras essentiel min »;SI(ET(G14>6;G14<13);« Athlète »;SI(ET(G14>14;G14<17);« Actif »;SI(ET(G14>18;G14<25);« Sédentaire »;SI(ET(G14>25);« Obèse »;ET(SI(G10=« Féminin »;SI(ET(G14>10;G14<13);« Grasse essentiel min »;SI(ET(G14>6;G14<20);« Athlète »;SI(ET(G14>21;G14<24);« Actif »;SI(ET(G14>25;G14<31);« Sédentaire »;SI(ET(G14>31);« Obèse »;””)))))))))))))

Merci d’avance :slight_smile:

Bonjour,

avant toute chose, le test de la valeur en cellules G14 ne peut fonctionner :
Par exemple, si sa valeur est 5 ou 6 (pour masculin), la formule ne renvoie pas de valeurs.

Sauf si certaines valeurs ne seront jamais en G14 ?!

En attendant votre réponse, la formule modifiée et fonctionnelle :

=SI(ET(G10="Masculin";G14>2;G14<5);"Gras essentiel min";SI(ET(G10="Masculin";G14>6;G14<13);"Athlète";SI(ET(G10="Masculin";G14>14;G14<17);"Actif";SI(ET(G10="Masculin";G14>18;G14<25);"Sédentaire";SI(ET(G10="Masculin";G14>25);"Obèse";SI(ET(G10="Féminin";G14>10;G14<13);"Grasse essentiel min";SI(ET(G10="Féminin";G14>6;G14<20);"Athlète";SI(ET(G10="Féminin";G14>21;G14<24);"Actif";SI(ET(G10="Féminin";G14>25;G14<31);"Sédentaire";SI(ET(G10="Féminin";G14>31);"Obèse";""))))))))))

Merci beaucoup pour votre réponse votre formule fonctionne. Effectivement, lorsque le résultat est 2, 5 pour masculin la formule ne renvoie pas de valeurs. Le même problème constaté pour le reste des valeurs. J’ai essayé G14>=2;G14<=5 mais cela n’a pas fonctionné ?

J’ai réussi à résoudre le problème, il suffit juste d’inverser ma condition donc j’ai commencé par : G14<=5;G14>=2 et j’ai eu un résultat :smiley: Merci bcp pour votre aide :slight_smile:

Tant mieux si la solution convient et qu’en plus vous avez su la modifier pour la rendre complètement opérationnelle :slight_smile:

Bonne journée à vous et peut-être à bientôt :wink:

1 J'aime