Pb avec la formule INDIRECT

Bonjour,

J’ai besoin de calculer la somme d’une plage qui commence toujours en A1 jusqu’à A20 par exemple pour l’exemple, j’inscrit donc :
=SOMME(A1:A20)
Mais ce ne sera pas toujours la ligne 20, donc en cellule D1, j’inscrit le N° de ligne qui m’intéresse et pour la récupérer j’ai un soucis, je ne vois pas comment faire, j’ai essayer cela :
=SOMME(INDIRECT(« A1:A »;D1);0)
=SOMME(INDIRECT(« A1:A »;D1))
je ne trouve pas la bonne méthode, si vous pouviez m’aider ?

Heu… j’ai trouvé, je me suis trompé, il faut mettre & à la place de ; donc :
=SOMME(INDIRECT(« A1:A » & D1))

Bonjour,

En fin de compte si j’ai un soucis avec indirect, c’est quand c’est plus imbriqué.

Dans le même ordre d’idée pour remplacer cette formule qui fonctionne :
= MOYENNE.SI(A1:A20;1;B1:B20)
en remplaçant 20 par la cellule D1 ou la valeur 20 est inscrite, j’ai essayé ces 2 formules : :
= MOYENNE.SI(INDIRECT(« A1:A » & D1 & « ;1;B1:B » & D1);VRAI)
= MOYENNE.SI(INDIRECT(« A1:A » & D1 & « ;1;B1:B » & D1))

Je ne trouve pas comment faire

Bonsoir Khalle,

Essaie :
=MOYENNE.SI(INDIRECT("A1:A"&D1);1;INDIRECT("b1:b"&D1))
Cordialement.

Bonjour Zebulon,

Ca marche nickel, un grand merci !