Meilleur score en golf

Bonjour
je cherche à identifier pour chacun des 18 trous d’un parcours de golf à quel parcours du challenge effectué le meilleur score du trou à été effectué.
Cela me permettrait d’éviter la formule ci après :
=SI(J7<AH7;SI(L7<AH7;SI(N7<AH7;SI(P7<AH7;SI(R7<AH7;SI(T7<AH7;SI(V7<AH7;SI(X7<AH7;SI(Z7<AH7;SI(AB7<AH7;SI(AD7<AH7;SI(AF7<AH7;“x”;$AE$4);$AC$4);$AA$4);$Y$4);$W$4);$U$4);$S$4);$Q$4);$O$4);$M$4);$K$4);$I$4)
Slts.

Classement .xlsx (225,8 Ko)

Bonjour,

Un fichier sera plus utile qu’une image.
Cordialement.