Macro double clic


#1

Bonjour à tous,

J’essaye désespéramment de trouver une solution à mon souci mais je jette l’éponge, et fais appel à votre (précieux) conseils:

J’essaye de lancer une macro lors de l’événement “double_clic” sur une cellule spécifique. Tout fonctionne, mais parfois, la cellule s’active (curseur clignotant) et la macro ne s’exécute pas…
Je ne trouve pas le souci. Si vous avez une idée, je suis preneur ça commence à me prendre vraiment la tête !!!

Je vous remercie, et vous souhaite une belle journée.

Thierry Guyot de la H.


#2

Bonjour Thierry,
Soit ton double clic n’est pas assez rapide ce qui fait que tu te retrouve en mode modification. Mais il serait intéressant d’analyser ton code. Peut-être qu’un autre événement serait envisageable.
Veux-tu bien ajouter ton fichier.

Bien à toi


#3

Bonjour CordierEt,

Je te remercie de prendre le temps de me répondre. Mais le souci ne vient pas de la vitesse du double clic, car je viens de me rendre compte que ce sont toutes les macros qui semblent sont désactivées (du moins les macros associées à des événements).
C’est étrange car lorsque je ferme et ré-ouvre le ficher, toutes les macros re-fonctionnent à nouveau.
J’aimerais bien vous transmettre mon fichier mais c’est classé confidentiel …
Si vous n’avez pas d’idée, je me débrouillerait autrement.

Merci encore :slight_smile:

Thierry Guyot de la Hardrouyère


#4

Bonjour Thierry,
Place le fichier qui te préoccupe et ainsi on pourra le tester.


#5

Bonjour CordierEt,

Merci pour ta réponse. Finalement j’ai trouvé: j’étais en mode création … je n’avais pas remarqué car j’ai caché tous les bandeaux, barre de formule, etc …

Merci encore et bonne journée :slight_smile:


#6

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.