J’ai un problème au niveau de la fonction RECHERCHEV


#1

Salut Moi c’est HABA PE
En fait, j’ai un problème au niveau de la fonction RECHERCHEV.
Supposons que nous avons un tableau à 7 colonnes qui comporte les entêtes
suivantes: Code client; Noms; Prenoms; Civilité;Adresse; Code postal;
Ville. Mais nous voulons avoir les information d’un même client à la fois
en utilisant la fonction RECHERCHEV. Comment faire cela?
Deuxième problème: Comment faire la somme des nombres se trouvant dans des
cellules de même couleur?


#2

#3

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?

Merci et à bientôt


#4

Merci beaucoup de l’intérêt que vous portez sur mes difficultés
En fait je vous envoie un fichier pour vous faciliter la tâche

Cordialement
HABA PE

Classeur des fonctions recherchesV et SOMME SI COULEUR.xlsx (12.8 KB)


#5

Bonsoir Pe_Haba, @DocteurExcel,

Merci de nous faciliter la tâche :wink:

Voici une proposition:

Pour la feuille "RECHERCHEV"
En “J4”

=SIERREUR(RECHERCHEV($I4;Tableau1;COLONNE()-8;0);"")

Tirer vers la droite autant que nécessaire.

En ce qui concerne la feuille “SOMME_COULEUR”

Il manquait la Fonction VBA, donc ça ne pouvait pas fonctionner.

Function SOMME_SI_COULEUR(PlageSomme As Range, PlageCouleur As Range) As Variant
 
 Dim Cel As Range
 Dim Som As Double
 Application.Volatile
    If PlageCouleur.Cells.Count > 1 Then
        SOMME_SI_COULEUR = CVErr(xlErrValue)
    Exit Function
    End If
        For Each Cel In PlageSomme
            If Cel.Interior.ColorIndex = PlageCouleur.Interior.ColorIndex Then Som = Som + Cel
        Next
        
 SOMME_SI_COULEUR = Som
 
End Function

Et pour faire le recalcule de la feuille automatiquement, j’ai ajouté un bouton “Go” associé avec cette macro.

 Sub ReCalcule()
    Calculate
End Sub

:warning: Respecter les bonnes couleurs, même vert, même rouge.

Ton fichier en retour ICI==> Pe_Haba V1.xlsm (22,8 Ko)

Cordialement.


#6

En fait merci beaucoup pour ce grand travail. Mais une seule chose reste.
Je voudrais savoir pourquoi la présence de “COLONNE”’()-8 dans la formule
de la fonction RECHERCHEV alors que le nombre des colonnes du tableau est
7? Un peu d’éclaircissement s’il vous plait.

Merci


#7

Bonjour Pe_Haba,

Chaque jour mérite bien un nouveau bonjour ! :wink:

COLONNE()-8 c’est une astuce pour éviter d’écrire =RECHERCHEV($I4;Tableau1;2;0) et à chaque fois changer le no_index_col et comme je commence a écrire la formule à la colonne “J” et que ma première valeur recherchée est en colonne “B” cela fait donc -8 colonnes.

Le =SIERREUR(formule;"") permet d’éviter les #N/A si une valeur recherchée est fausse en “I4”.

Voilà pour les explications.

Si ton probleme est resolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Cordialement.


#8

Vous m’excusez d’abord par ce que j’ai pas commencé par vous saluer.
Je suis très satisfait et j’ai fait un exemple dans la colonne J, ça marché

Merci baucoup

Mais je voudrais savoir: Est ce que vous donnez des certificats
internationaux et quels sont les domaines? Si oui quelles sont les
démarches à suivre?


#9

Re Pe_Haba,

:roll_eyes: :thinking::interrobang: De quoi me parles-tu ?

Ici nous sommes sur un forum et je ne pense pas que nous distribuons quelques “certificats, brevets où autres choses de ce genre” enfin je ne crois pas, sinon faire une demande expresse à @DocteurExcel :joy: le concepteur du forum, peut-être est-il à même de te délivrer une ordonnance :blush:

Si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Bonne fin de journée.