Formule SIVIDE via deux cellule

Bonjour,
Voila mon problème je suis pas expert en formule, mais voila en détails mon problème :

Cellule H7 : =SI(H11="";"";SOMME(F11:F100))
Cellule Q7 : =SI(Q11="";"";SOMME(O11:O100))

Cellule A1 : =SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0)

Voila mais si la cellule H7 et Q7 ne contient pas de valeur, la cellule A1 Affiche 0

J’ai trouver cette formule : =SI(H7="";"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))

Mais sa ne prend en considération que H7 et non Q7 je ne sais pas comment faire genre : Que A1 = VIDE Sauf si H7 ou Q7 contient une valeur alors formule. (En prenant en considération la formule de A1)

Merci beaucoup si vous pouvais m’aidez a trouver une formule.

Bonjour,

As tu testé ET et OU ?
=SI(ET(H7="";Q7="");"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
=SI(OU(H7="";Q7="");"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
A tester, sinon envoie ton fichier que l’on puisse trouver une solution.
Cordialement.

1 J'aime

Super énorme sa fait plus de 3h que je suis dessus et tu ma trouvé la formule, effectivement le ET fonctionne :slight_smile:

Merci beaucoup !!!

De rien, bonne continuation. Mets la demande en résolu si c’est le cas.
Cordialement.

Juste pour être sur.
J’ai coché solution sur votre explication juste avant, celas valide la demande en résolu ? ou y’a t’il une autre démarche à faire ?

Bonsoir,

C’est ok.
Cordialement.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.