Formule si cellule A1 contient un texte ajoute texte dans cellule B2


#1

Bonjour,

Si ma cellule A1 contient le texte qui se trouve dans colonne C, je souhaite écrire le texte en cellule B1

Example:
Colonne A contient les phrases:
A1) Brian May travaille dans une banque
A2) Elle s’appelle Carol Marchal
A3) Que Peter King ira à

Colone C contient une liste de noms:
C1) Carol Marchal
C2) Peter King
C3) Brian May

Je souhaite extraire les noms qui se trouvent dans la colonne A et les lister dans la colonne B.
Resultas:
B1) Brian May
B2) Carol Marchal
B3) Peter King

Merci pour votre aide.


#2

Bonjour @Bwild,

La prochaine fois, mieux vaut joindre un fichier exemple, sinon cela nous oblige a le créer:

Pour joindre un fichier:

Joindre%20un%20fichier

Toutefois voir cet exemple si cela peut convenir.

En “B2”

=SIERREUR(INDEX($C$2:$C$5;MAX(SI(ESTERREUR(CHERCHE($C$2:$C$5;A2));-1;1)*(LIGNE($A$2:$A$5)-1)));"Non Trouvé")

Formule matricielle a valider avec les touches ctrl + maj + entrée

Tirer vers le bas autant que nécessaire.

Fichier ICI==> Bwild 27 09 2018.xlsx (10,4 Ko)

Cordialement.


#3

Merci beaucoup, ca marche super bien!