Formule pour trouver un mot

Bonjour la communauté

Voila mon problème dans le classeur essaie que je vais vous présenter j’ais mis en couleur jaune colonne “L2”

une formule que je tire vers le bas pour me donnée le chiffre " 1 " comme en " L2 " mais les autre cellule ne

suive pas je me retrouve avec " #N/A " alors qu’avant c’la fonctionnait très bien.

Et maintenant je suis obligé de faire tout manuellement

Peut-être que @mdo100 pourrait me venir en aide étant le spécialiste des formules :wink:

Voici le fichier EX:==> Classeur1ESSAIE.xlsx (16,9 Ko)

Cordialement

@kiss6

Bonjour,

Pour résoudre le problème, il serait bon de savoir ce que tu recherches dans la formule, car là, il ne recherche l’EQUIV à partir du 36 ème caractère de ta ligne
Et je doute que cela fonctionnait auparavant, à mois que par hasard le caractère soit au même emplacement

Si toutefois, c’est les courses contenant le mot Plat, teste cette formule

=SIERREUR(SI($L$1=0;"";SI(J2=0;"";INDEX($F$2:$F$7;EQUIV(STXT(J2;TROUVE("Plat";J2);CHERCHE("";J2;4)+0);$E$2:$E$7;0))));"")

1 J'aime

Bonjour @kiss6,

En “L2”

=SIERREUR(SI($L$1=0;0;INDEX($F$2:$F$7;EQUIV(VRAI;ESTNUM(CHERCHE($E$2:$E$7; J2));0)));"")

Formule matricielle a valider avec ctrl + maj + entrée

Salut @Mimimathy, trop rapide pour moi :wink:

Cordialement.

2 J'aimes

Re bonjour @Mimimathy

je vous remercie pour cette réponse rapide elle fonctionne très bien mais le problème c’est quelle fonctionne

que pour le mot " plat " et je vous garanti qu’ avant c’la fonctionnait car c’est un programme que j’avais acheté

mais je vais vous remettre un fichier ex: car j’avais oublié une seconde réunion donc voici le deuxième

classeur ===> Classeur1ESSAIE.xlsx (17,1 Ko)

Cordialement

@kiss6

" ps: ne m’engueuler pas" :wink: :face_with_raised_eyebrow:

Salur MDO, plus rapide, mais moins bon, ma formule ne recherche que pour le Plat :-1:

Re bonjour @mdo100

Merci pour votre formule mais contrairement a celle de @Mimimathy elle ne donne aucun résultat

je croyais que vous étiez en colère contre moi @mdo100 car je vous est salué sur un post et aucune réponse

:wink:

Cordialement

@kiss6

As-tu lu les réponses jusqu’au bout

" ps: ne m’engueuler pas" :wink: :face_with_raised_eyebrow:

Si, si, on va crier :laughing:

2 J'aimes

Re @kiss6,

  1. Suivre les conseilles de @Mimimathy,

Je ne suis pas 24/24 sur le forum, je ne peux donc pas tout voir.

Cdlt.

1 J'aime

Re @Mimimathy ; @mdo100

Autant pour moi désolé @mdo100 c’est vrais c’la fonctionne oublié le " ctrl + maj + entrée " toute mes excuse

@kiss6

Re

Merci a vous deux pour moi c’est résolue :+1: :wink:

Cordialement @kiss6