Expliquer la formule


#1

Bonjour

Quelqu’un est capable d’expliquer cette formule.
Elle marche très bien pour compter mais je ne la comprends pas; Je n’arriverai pas à la refaire si je ne la comprends pas
merci

test.xlsx (9,7 Ko)

{=SOMME((FREQUENCE(SI(code="";"";SI(SOUS.TOTAL(3;DECALER(C3;LIGNE(code)-LIGNE(C3);));EQUIV(code;code;0)));LIGNE(code)-1)>0)*1)