Excel 2010 calcul max et moyenne vba


#1

Bonjour à tous,

je vous écris aujourd’hui afin d’avoir des solutions pour un petit problème.En fait j’ai un fichier excel composé de trois sheets,dans le sheet calcul moyenne,si vous voulez je veux que si le valeur obtenu de E3 est négatif, rajouter ce valeur aux deux cellules précédentes pour qu’il reste la somme de (C2+D2+E2=C3+D3+E3),et je donne 0 pour ce cellule dans le cas ou le résultat est négatif.
Voici ci-joint le fichier merci bcp pour votre aide .

Classeur TEST RESULTAT.xlsm (139,7 Ko)


#2

Bonsoir @mhk10,

Voici une proposition par formule:

En “D3”

=SI(OU(C2=0;D2=0;E2=0);MOYENNE(MIN(SI(C2:E2<>0;C2:E2)));PETITE.VALEUR(C2:E2;1)+PETITE.VALEUR(C2:E2;2))

Formule matricielle a valider avec ctrl + maj + entrée

Copier / coller cette formule dans les autres cellules, je l’ais fait sur le fichier.

Ton fichier en retour ICI==> TEST RESULTAT mhk10 V1.xlsm (141,6 Ko)

Cordialement.