Durée exacte d'une mission


#1

Aidez moi a faire afficher la durée entre le 26/01/2017 00:10:00 et le 06/05/2017 17:00:00 sous la forme jours heures minutes
Merci


#2

Bonjour

Un test
Nasser.xlsx (9,9 Ko)


#3

En fait l’affichage doit êtetre sous la forme jours heures minutes.


#4

Re

comme ceci
=DATEDIF(A2;B2-1;“d”)&" jour(s) et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);“hh:mm”)


#5

Bonsoir @Nasser_Boubacar_Tall, @Mimimathy,

@Nasser_Boubacar_Tall, Un bonjour où un bonsoir n’a jamais tué personne !

En “A2” 26/01/2017 00:10:00
En “B2” 06/05/2017 17:00:00

En “C2” =ENT(B2-A2)&" jours "&TEXTE(MOD(B2-A2;1);"[hh]:mm:ss")

Cordialement.


#6

bonjour
Je vous remercie pour la diligence mais je crois qu’il y a une erreur dans la formule suivante :
=DATEDIF(A2;B2-1;“d”)&" jour(s) et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);“hh:mm”)

le premier test est meilleur sauf que si possible je souhaite afficher le résultat sous la forme :
100 jours 16 heures 50 minutes
lorsque
En “A2” 26/01/2017 00:10:00
En “B2” 06/05/2017 17:00:00
en attendant votre réponse, je vous souhaite un bon réveil.


#7

Je vous remercie pour la diligence mais je souhaite afficher le résultat sous la forme :
100 jours 16 heures 50 minutes
lorsque
En “A2” 26/01/2017 00:10:00
En “B2” 06/05/2017 17:00:00
en attendant votre réponse, je vous souhaite un bon réveil.


#8

Bonjour @Nasser_Boubacar_Tall,

=SI(ENT(B2-A2)<1;HEURE((B2-A2)-ENT(B2-A2))&" heures "&MINUTE((B2-A2)-ENT(B2-A2))&" minutes";SI(ENT(B2-A2)<2;ENT(B2-A2)&" jour "&HEURE((B2-A2)-ENT(B2-A2))&" heures "&MINUTE((B2-A2)-ENT(B2-A2))&" minutes";ENT(B2-A2)&" jours "&HEURE((B2-A2)-ENT(B2-A2))&" heures "&MINUTE((B2-A2)-ENT(B2-A2))&" minutes"))

Cordialement.


#9

Infiniment MERCI à ce forum.