Dièses dans soustraction heures (résultat = 0)


#1

Bonjour,

J’ai un fichier Excel avec plusieurs onglets. Dans chaque
onglet il y a une soustraction entre 2 cellules au format [h]:mm:ss

Quand le résultat est positif, pas de souci mais quand il
est à zéro, ça m’affiche des dièses. Ce que je ne comprends pas du tout c’est
que ça dépend des heures que je saisi (voir fichier joint pour mieux comprendre bug excel.xlsx (14,5 Ko)
; avec certaines heures ça fonctionne, avec d’autres non (c’est la cellule J27 qui bug)

Pour information, quand je coche l’option “calendrier 1904” le
résultat passe de dièses à “-0:00:00”

C’est un mystère pour moi…

Merci pour votre aide


#2

Bonjour

Oui le format date ou heure bug lorsque la date/heure est négative
La valeur n’est pas calculée de manière exacte par Excel.

Pour être sur que cela fonctionne, remplace par =+MAX(E25-J25;0) dans ta cellule pour être sur que c’est bine positif


#3

Bonjour @Claire,

Le “calendrier 1904” peut effectivement résoudre le problème des heures négatives.

Un des inconvénients du “calendrier 1904”, c’est que les dates prennent + 4 ans et quelques jours, fait l’expérience en mettant la date du 05/01/2018, tu auras alors la date du 06/01/2022.

Car Excel ne reconnaît pas les dates avant 1900.

On peut contourner ce problème avec cette formule:

En “J27”

=SI(E25<J25;"- "&TEXTE(J25-E25;"hh:mm");E25-J25)

Mais il y a aussi un inconvénient avec cette formule, c’est que la partie négative est au format “TEXTE”, ce qui peut être un autre problème pour d’autres calcules.

Donc à toi de choisir.

Ton fichier en retour ICI==> Claire bug excel.xlsx (16,4 Ko)

Cordialement.

Edit: Bonjour @DocteurExcel,


#4

Merci, cela fonctionne avec =+MAX(E25-J25;0) !


#5

Re @Claire,

Je n’en doute pas, mais si “J25” est supérieur à “E25” tu auras toujours “0:00:00” :crazy_face:

Cdlt.


#6

J25 ne peut pas être supérieur à E25 car les salariés ne récupèrent que les heures sup qu’ils ont faites ; il ne récupèrent pas d’heures s’il n’ont pas faire d’heures sup avant :yum:

Donc c’est bon :grinning: