Créer une nouvelle variable avec un code boucle


#1

Bonjour à tous
Je suis un nouveau
Voici mon problème
Je dispose des données sur des individus appartenant à un ménage
dans ma feuille excel j’ai :
Colonne A : Numéro des ménages (1 à 108000)
Colonne B : Génération des individus dans le ménage (Enfants, Adulte, Personne Agée)
Colonne C : Lien de parenté (Parenté au chef ménage, Pas parenté au chef ménage)
Colonne D : Générer une variable (Personne Agée parentée au Chef Ménage et vit avec adulte seulement)

Voilà mon code attribuer la valeur 1 à tous les individus appartenant au ménage dont le critère de la colonne D est vérifié.
Voilà depuis je tourne en rond.
Merci de m’aiderExtrait_Recherche_These.xlsx (11,0 Ko)


#2

Bonjour et bienvenue

pour ta demande fourni un classeur exemple de 10/15 données (anonymisées) avec une explication (voire le résultat à réaliser)
image


#3

Merci beaucoup Mimimathy
Je viens d’envoyer le fichier demandé
Cordialement


#4

Bonjour,

Si j’ai compris, formule à mettre en D2 et la tirer vers le bas
=SI(ET(B2<>1;C2<>3);1;"")


#5

Bonjour Mimimathy
Réponse reçue
Mais ce n’est pas le résultat que je recherche parmi les ménages qui répondent aux critères de donner 1 à tous individus portant le même numéro de ménage et 0 sinon.
Merci
Cordialement


#6

Re,

Eh bien montre des exe mples de ce que tu veux obtenir manuellement


#7

Ok!!!
C’est çà dans ce fichier
Extrait_Recherche_These.xlsx (13,6 Ko)


#8

Re,

Ok, je regarde, mais cela surement en VBA (macro)


#9

OK
J’attends, mais il faut utiliser certainement un boucle


#10

Re,

Un peu plus que une …


#11

Affichage de la valeur de la variable dans une boîte de dialogue Sub variables() 'Déclaration de la variable Dim ma_variable As Integer 'Attribution d'une valeur à la variable ma_variable = 12 'Affichage de la valeur de ma_variable dans une MsgBox MsgBox ma_variable End Sub


#12

Bonjour Habibwesberry
Message reçu
Vous pouvez écrire cela en code svp


fermé automatiquement #13

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.