Créer une formule s'appuyant sur 2 conditions dans 2 colonnes différentes pour définir un taux


#1

Fomule EXCEL.xlsx (8,6 Ko)
Bonjour

C’est la première fois que je fais appel à un forum. Je n’arrive pas à prendre en compte deux conditions pour définir un taux
Merci de ce que vous pourrez m’apporter

J’ai besoin d’aide pour écrire une formule tenant compte de 2 conditions dans 2 colonnes différentes
En colonne 2 le groupe d’appartenance et en colonne 3 le nombre de points
on a 4 groupes différents : A1, A2, B1 et C1 pour chaque groupe on a différents choix
A1 : Si nbre de pts>30= 100%, si nbre de pts>20= 75% sinon 50%
A2 : Si nbre de pts>50 = 100% si nbre de points>30=75% sinon 50%
B1 : Si nbre de pts>30 = 100% sinon 75%
C1 : si nbre de pts>20 = 100% sinon 75%

Comment imbriquer ces deux conditions pour définir le bon pourcentage


#2

Hello mancola,
L’ordre degresif des points est bien rangé. L’imbrication se fait en général comme suit :
=Si(Test, vrai, si( Test, vrai,faux)).

Si le test implique plusieurs conditions obligatoires comme ici, il faut les intégrer dans un ET comme ceci :=si( Et(cond1,cond2) ,vrai;faux)
Ce qui donne ceci avec tes conditions :
=SI(ET(C2=“A1”;D2>30);100%;SI(ET(C2=“A1”;D2>20);75%;SI(C2=“A1”;50%;SI(ET(C2=“A2”;D2>50);100%;SI(ET(C2=“A2”;D2>30);75%;SI(C2=“A2”;50%;SI(ET(C2=“B1”;D2>30);100%;SI(C2=“B1”;75%;SI(ET(C2=“C1”;D2>20);100%;75%)))))))))

Je te propose ceci (pas très beau) , confirme si cela fonctionne en marquant le post comme résolut.
Fomule EXCEL.xlsx (10,5 Ko)


#3

Merci pour ce retour rapide et efficace
Bonne journée