Création tableau

Bonsoir,

Je viens vers vous car je rame, et je rame encore plus que mon pc. Je ne pense pas être trop mauvaise avec excel mais la c’est le FLOP.

J’ai un tableau excel avec le nom des agents, des clients les horaires de jours, de nuits, les horaires en jours fériés, et dimanche (le tableau est fait avec des formules). Le soucis c’est que maintenant mon patron me demande une feuille supplémentaire qui calculerai automatiquement par rapport au nom client que l’on marquera les heures de jours, de nuits, les heures dimanche jours les heures dimanches nuit et heures de jours pour les jours fériés et les heures de nuits (en sachant que les heures de nuit sont de 21:00 à 06:00). Pensez vous que vous pourriez m’aider?
j’espere que l’on comprendra ma demande… :sweat:

Je vous en remercie d’avance.

Bonsoir @titiche,

Oui, bien sûr mais avec un fichier sur lequel on peut travailler.

Pour joindre un fichier suivre la procédure ci-dessous:

Joindre%20un%20fichier

Cordialement.

Planning octobre modele pour test NE PAS TOUCHER.xlsm (284,0 Ko)

Bonsoir mdo100?

J’ai oublié de préciser que dans le tableau (feuille planning) il faut que je rajoute des colonnes afin de différencier les heures de jours et nuits pour les dimanches et les jours fériés.

merci d’avance, si tu me trouves la solution.

Bonjour @titiche,

Déjà les feuilles sont protégées avec un MdP, j’ai dû le déverrouiller pour pouvoir y accéder.

Autre chose une feuille supplémentaire ?

Où des colonnes supplémentaires dans la feuille "Planning"

Mettons nous déjà d’accord sur la demande! Merci de me confirmer.

Sinon laisse moi le temps de me plonger dans le fichier, donc un peu de patience.

Cordialement.

Bonjour @mdo100

Oui dsl pour le mdp. Je te laisse le temps. Y a pas de soucis

@mdo100 oui j’ai plusieurs feuilles que j’ai renommé planning, liste client …

re @mdo100,

la je suis sur mon pc pour répondre c’est mieux qu’avec le tel.

Déja, je te remercie de l’aide que tu veux bien m’apporter et en fait il faut des colonnes supp et également une autre feuille .

Je te laisse le temps pas de soucis, car la je sature.

Merci

Re @titiche,

Pour le moment voilà ou j’en suis:

Le plus difficile se sont les chevauchements des jours, là j’ai attaqué les Dimanche Jour & Nuit, mais quand je vais en plus faire les chevauchements des jours avec les Fériés Jours & Nuit, ça va se compliquer.

Au vu de cette capture d’écran, dis-moi si cela convient !

Mais ne t’attends pas a un résultat final aujourd’hui ==> Nuit difficile, alors très fatigué :pensive:

Cdlt.

@mdo100, oui cela me convient bien, et tkt je ne m attends a rien aujourd’hui, et nuit difficile pour moi aussi car je suis restée sur Excel jusqu a 4h00. Je ne vais pas demandé à ce que cela soit fait dans les 24h c’est déjà très gentil de ta part de m aider.

Bonjour @titiche,

Voici donc ma proposition, attention ça pique un peu les yeux. :sunglasses: mais ça fonctionne.

Il y a aussi une grosse magouille dans la colonne “P” avec une MFC, mais comme j’avais des références circulaires et que je ne m’en sortais pas, alors j’ai paré à la simplicité :roll_eyes:

En "O13"

=SI(NB.SI('Jour ferié'!$B$1:$B$14;D13)>0;
SI(JOURSEM(D13)>1;SI(L13>0;0;MOD(V13-P13;1))-(Q13+R13);SI(JOURSEM(D13)<>1;SI(L13>0;0;MOD(V13-P13;1));0))+SI(ET(JOURSEM(D13)=1;J13>Fin;J13<Deb);MOD(J13-Fin;1);0)-S13;
SI(JOURSEM(D13)>1;SI(L13>0;0;MOD(V13-P13;1))-(Q13+R13);SI(JOURSEM(D13)<>1;SI(L13>0;0;MOD(V13-P13;1));0))+SI(ET(JOURSEM(D13)=1;J13>Fin;J13<Deb);MOD(J13-Fin;1);0))

En "P13"

=SI(JOURSEM(D13)>1;SI(L13>0;0;SI(ET(I13>=J13;I13<=Deb;I13<>0;J13<>0);MOD(Fin-Deb;1)-SI(J13<=Fin;Fin-J13)+SI(I13<=Fin;Fin-J13);SI(ET(I13>=J13;I13>Deb;I13<>0;J13<>0);MOD(Fin-Deb;1)-(I13-Deb)+SI(J13>=Deb;J13-Deb)-SI(J13<Fin;Fin-J13);SI(ET(I13<J13;ESTNUM(I13);J13<>0);SI(ET(I13<=Fin;J13<=Fin);J13-I13)+SI(ET(I13<=Fin;J13>Fin);Fin-I13)+SI(J13>=Deb;J13-I13-SI(I13<=Deb;Deb-I13));0))))-R13;0)

En "Q13"

=SI(SI(JOURSEM(D13)>1;SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))-R13;SI(JOURSEM(D13)=1;SI(L13>0;0;MOD(V13-P13;1));0))-(R13+SI(ET(JOURSEM(D13)=1;J13>Fin;J13<Deb);MOD(J13-Fin;1);0))>0;SI(JOURSEM(D13)>1;SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))-R13;SI(JOURSEM(D13)=1;SI(L13>0;0;MOD(V13-P13;1));0))-(R13+SI(ET(JOURSEM(D13)=1;J13>Fin;J13<Deb);MOD(J13-Fin;1);0));SI(JOURSEM(D13)>1;SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))-R13;0))

En "R13"

=SI(JOURSEM(D13)=1;SI(L13>0;0;SI(ET(I13>=J13;I13<=Deb;I13<>0;J13<>0);MOD(Fin-Deb;1)-SI(J13<=Fin;Fin-J13)+SI(I13<=Fin;Fin-J13);SI(ET(I13>=J13;I13>Deb;I13<>0;J13<>0);MOD(Fin-Deb;1)-(I13-Deb)+SI(J13>=Deb;J13-Deb)-SI(J13<Fin;Fin-J13);SI(ET(I13<J13;ESTNUM(I13);J13<>0);SI(ET(I13<=Fin;J13<=Fin);J13-I13)+SI(ET(I13<=Fin;J13>Fin);Fin-I13)+SI(J13>=Deb;J13-I13-SI(I13<=Deb;Deb-I13));0))));SI(JOURSEM(D13)=1;0;SI(SI(ET(JOURSEM(D13)>1;I13<Deb);SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))-MOD(Deb-I13;1);SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13))))<0;0;SI(ET(JOURSEM(D13)>1;I13<Deb);SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))-MOD(Deb-I13;1);SI(L13>0;0;((I13>J13)*((JOURSEM(D13)=7)*J13+(JOURSEM(D13)=1)*(1-I13))+(I13<J13)*(JOURSEM(D13)=1)*(J13-I13)))))))

En "S13"

=SI(NB.SI('Jour ferié'!$B$1:$B$14;D13)=0;0;SI(SI(MOD(J13-I13;1)<>MOD(Deb-Fin;1);0;MOD(J13-I13;1))<>0;SI(MOD(J13-I13;1)<>MOD(Deb-Fin;1);0;MOD(J13-I13;1));SI(SI(ET(L13>0;NB.SI('Jour ferié'!$B$1:$B$14;D13)>0;J13>Fin);0;MOD(V13-P13;1)-MOD(J13-Fin;1))<0;SI(ET(L13>0;NB.SI('Jour ferié'!$B$1:$B$14;D13)>0);0;MOD(V13-P13;1));SI(ET(L13>0;NB.SI('Jour ferié'!$B$1:$B$14;D13)>0;J13>Fin);0;MOD(V13-P13;1)-MOD(J13-Fin;1)))))

En "T13"

=SI(NB.SI('Jour ferié'!$B$1:$B$14;D13)>0;V13-(S13+O13);0)

J’ai mis des valeurs dans les colonnes “I & J” pour faire mes testes, j’ai également mis la date du 01/01/2018 dans “D138 à D141” pour simuler un jour férié, il suffit de remettre les bonnes dates.

Ton fichier en retour ICI==> Planning octobre modele pour test NE PAS TOUCHER V0.xlsm (352,2 Ko)

Cordialement.

Bonsoir @mdo100,

En effet cela pique les yeux lol, mais franchement je te remercie, j’étais loin de faire autant de formules.

Mille merci, je montre cela à mon boss lundi (et je ne me venterais pas d’avoir fais le changement car il risque m’en demander encore et encore :sweat:

Merci encore,

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.