Création tableau dynamique pour championnat


#1

Bonjour,

Je suis responsable d’un club de poker et j’ai réalisé un tableau sous excel pour le calcul automatique du championnat.

Sur la feuille1 (Classement étape):
_ un tableau avec tout les joueurs du club et leur places obtenue lors de chaque étapes, rentré manuellement.

Sur la feuille2 (Calcul des points):
_ un tableau avec tout les joueurs du club avec leur nombres de points par étapes calculé automatiquement.
_ Formules employé pour le calcul:
=SIERREUR(1+K5-$‘Classement étapes’.L9;0)

Sur la feuille3 (Classement général):
_ un tableau dynamique qui calcul automatiquement le classement du championnat.
_ Formules employé pour la mise en ordre des noms des joueurs dans le classement:
=INDEX($‘Calcul des points’.B$8:B$53;EQUIV(D8;$‘Calcul des points’.U$8:U$54;0))
_ Formule employé pour la mise en ordre des points des joueurs (en relation avec leur nom):
=GRANDE.VALEUR($‘Calcul des points’.U$8:U$53;LIGNES(D$7:D7))

Problème: le tableau sur la feuille3 ne gère pas les ex-æquo et c’est assez embêtant.

Auriez vous La solution svp?


#2

Bonjour

Peux-tu joindre ton fichier ce qui sera plus pratique pour visualiser le problème stp?

A bientôt


#3

Bonsoir, ci dessous le fichier

Tableau de calcul du championnat 2016-17.xlsx (27,7 Ko)


#4

Bonjour @Frederic_Caetano,
Salut @DocteurExcel,

@Frederic_Caetano une proposition gestion rang sans doublon.

Dans la feuille “Calcul des points” colonne “L” “Position”.

En “L8”:

=SIERREUR(RANG(K8;$K$8:$K$40)+NB.SI(K$8:K8;K8)-1;"")

Tirer vers le bas autant que nécessaire.

Puis dans la feuille “Classement général” colonne “C” “PSEUDO”.

En “C8”:

=SIERREUR(INDEX('Calcul des points'!$B$8:$B$40;EQUIV($B8;'Calcul des points'!$L$8:$L$40;0));"")

Tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> Frederic_Caetano V1.xlsx (29,7 Ko)

Cordialement.