Convertir un nombre en texte sur Excel


#1

Publié initialement sur: https://www.formuleexcel.com/convertir-un-nombre-en-texte-sur-excel/

Par défaut lorsque l’on entre un nombre sur Excel, il est aligné vers la droite et considéré automatiquement comme un nombre. Il peut cependant arriver que l’on souhaite afficher ces nombres comme du texte, ou bien utiliser ces nombre pour construire un texte complexe. Nous allons voir tout de suite comment procéder.

Tutoriel en vidéo

https://www.youtube.com/watch?v=WuOozmCemB8

N’oublie pas de t’abonner pour recevoir directement les nouveaux tutoriels vidéos sur Excel:

➡️ Clique ici pour t’abonner

 

Convertir un nombre en texte avec un format

Pour utiliser le format texte, faites: Clic droit > Format de cellule puis sélectionnez Texte

foramtter un nombre en tant que texte avec Excel

Convertir un nombre en texte avec une apostrophe

Il suffit d'entrer une apostrophe au début de la cellule pour que toutes les données entrées soient considérées comme du texte.

convertir un nombre en texte avec un apostrophe

Convertir un nombre en texte avec la fonction TEXTE

La fonction TEXTE permet de convertir n'importe quelle donnée en texte. Elle a l'avantage de permettre l'utilisation de formats avancés.

Pour convertir tout simplement une cellule de chiffres en texte, utilisez la formule

=TEXTE(B3; "Standard")

Le résultat de cette formule est une chaîne de texte, vous pouvez alors la concatener avec d'autres morceaux de texte.

Pour ajouter un texte supplémentaire, il vous suffit d’entrer ce texte entre guillemets et de relier les différentes chaines de caractère entre elles par le symbole &.

chaine de caractères

Notez que vous pouvez également concatener directement le résultat d’une cellule numérique avec du texte, le résultat sera bien du texte. (Par exemple = "Résultat: " &B3 )

Convertir un nombre en utilisant un format spécial et la fonction texte

Précédemment nous avions utilisé le format standard, mais l'intérêt de la fonction TEXTE est surtout de spécifier des formats spéciaux.

Par exemple nous pouvons utiliser cette fonction pour calculer un pourcentage et l’inclure dans un texte avec la formule suivante:

= "Les ventes ont augmenté de " &TEXTE(B10; "0%")

utiliser un nombre formaté en pourcentage dans un texte

On peut également utiliser un format monétaire afin d’indiquer une monnaie:

= "Vous avez dépensé " &TEXTE(B13; "$#,##")

L'intérêt est que la cellule de départ n'a pas besoin d'être formatée correctement, la formule applique le format simplement à l'intérieur de notre texte

utiliser un nombre avec un format de monnaie dans une chaine de texte

 

 


Comment convertir un nombre en format texte dans excel