Convertir des colonnes en lignes

Bonjour la communauté c’la fait un bon moment que je ne suis pas venu sur le forum car celui ci ma beaucoup appris mais là je bloque sur un problème de colonnes a mettre en ligne
voila mon problème j’ais une séries de dates et par rapport a ces dates me compter le nombre de chiffres qui correspond a celle ci et me les positionner sur la même ligne je vous poste un classeur qui seras plus explicite si possible sans passer part du VBA
=====> Classement d’une colonne en ligne.xlsx (11,7 Ko)

bonjour le forum
voila j’ais trouvé cette formule matriciel pour le nombre de chiffre par date mais c’la me prend en compte les case vide " {=SOMME(SI(($A$7:$C$20=$F7);NB.SI.ENS($B$7:$B$20;2)+NB.SI.ENS($C$7:$C$20;2)))} "
si vous avez une solution elle sera la bien venue
Cdlt kiss6
PS: je vous joins le classeur avec la formule matriciel
======>Classement d’une colonne en ligne.xlsx (12,4 Ko)