Compter des cellules identiques

Bonjour, je cherche à compter le nombre de cellules identiques de B1 à B13 et d’inscrire en C le nombre et l’intitulé de chaque cellules identiques.
soit :
BC
Numéros calcul

1…3…2 numéros 3
2…3…1 numéro 4
3…4…1 numéro 5
4…5…1 numéro 6
5…6…1 numéro 7
6…6…5 numéros 8
7…6
8…7
9…8
10…8
11…8
12…8
13…8
Avez vous une solution à me donner ?
merci de votre aide

Bonjour @CDES,

Tester ceci:

En “C1”

=NB.SI($B$1:$B$13;LIGNE()+2)&" "&"N°"&" "&LIGNE()+2

Cordialement.

Bonjour et merci de votre réponse, mais ça ne répond pas entièrement à mon problème
dans ma colonne B j’'ai 12 000 référence à 6 chiffres je voudrais par une formule générale savoir combien j’ai de réf 505632, Combien de réf 657232 etc …
J’espère avoir été clair !!!
merci de votre aide
Cdt

Bonjour CDES
Salut MDO

Je pense qu’en mettant un p’tit classeur exemple correspondant à votre demande, MDO aurait sorti de son chapeau de formule, la BONNE :open_mouth:
Avec des inscriptions sur un post, chacun fait ce qu’il peut pour aider :wink:

1 J'aime

Re @CDES,
Re @Mimimathy,

J’ai répondu exactement à la demande faite, après si la demande change en cours de route, forcément que la réponse ne peut pas corresponde, nous ne sommes pas dans ta tête !

Cdlt.

Re @CDES,

Alors voici une proposition dans le fichier joint:

Colonne “B” Références
Colonne “D” Références Sans Doublons

En “D2”

=SI(MAX(D$1:D1)=MAX($B$2:$B$15);"";MIN(SI($B$2:$B$15>MAX(D$1:D1);$B$2:$B$15)))

Cette formule tien compte des éventuelles cellule vides.
Formule matricielle a valider avec ctrl + maj + entrée

Colonne “E” Nbr de Références en Doublons

En “E2”

=SI(NB.SI.ENS($B$2:$B$15;">0";$B$2:$B$15;D2)<>0;NB.SI.ENS($B$2:$B$15;">0";$B$2:$B$15;D2);"")

Cette formule a valider normalement tien compte des 0 et donc ne les affiches pas.

CDES V1.xlsx (10,8 Ko)

Cela convient-il ?

Cordialement.

ex 1.xlsx (11,5 Ko)
c’est presque ça, vous avez en pièce jointe le modèle xl avec les explications
encore merci
Cdt

Re @CDES,

C’est exactement ÇA, si tu avais correctement suivi mes instructions.

Ton fichier en retour ICI==> CDES V2.xlsx (10,8 Ko)

Cdlt.