Comparer automatiquement 2 feuilles


#1

Bonjour,

Je reviens vers vous une nouvelle fois pour savoir s’il est possible de comparer 2 feuilles automatiquement.
Dans le fichier d’exemple :
_ sur la feuille 1, en rouge, les lignes qui n’existe pas sur la feuille 2 ;
_ sur la feuille 2, en bleu les différences avec la feuille 1.
Copie de Exemple fichier 4.xlsx (20,4 Ko)
En réalité, la feuille 2 n’est pas triée bien évidemment.
J’aimerais que les deux feuilles se comparent l’une et l’autre, et que les lignes identiques apparaissent en vert et les autres en rouges ou quelque chose dans ce genre.
D’avance merci
D’avance merci


#2

Bonjour @Spiced,

Voici une proposition:

Avec l’ajout de 2 colonnes sur chaque feuille, les 2 colonnes peuvent être masquées.

Dans la feuille “Programmée”.

En “D2”

=A2&B2&C2

En “E2”

=SIERREUR(SI(RECHERCHEV(D2;Ralisée!$D$2:$D$311;1;0)=D2;1;0);"")

Même chose pour la feuille “Réalisée”.

Voir aussi les MFCs.

Et le fichier ICI==> Exemple fichier 4 Spiced V1.xlsx (40,4 Ko)

Cordialement.


#3

Vous avez été au Top !
MERCI !