Calculer une valeur pondérée


#1

Bonjour,

Quelle formule utiliser pour pondérer une valeur ? Par exemple
1 x 1,1 dans la limite 10.
Merci.


#2

Bonjour VANIERS, toutes et tous,

Je suppose qu’il s’agit de moyenne pondérée, car ta demande est un peu courte.
En partant du principe que les valeurs sont de “A1 à A10” et les coéf de “B1 à B10”.
Je te propose cette formule:

=SOMMEPROD(A1:A10;B1:B10)/SOMME(B1:B10)

Cela convient-il ?
Sinon précise ta demande.

Cordialement


#3

Bonjour et merci pour cette réponse.
En fait ma demande consiste à multiplier par 1.1 les dix premières heures et pas les suivantes.
Merci.


#4

Bonsoir VANIERS,

Peux-tu joindre un bout de fichier pour illustrer ta demande, ce serait plus facile d’apporter une réponse juste.
Pour joindre un fichier:

@+
Cordialement.


#5

Hello
Pour 10 valeurs, à la main ou par formule devrait suffire…
Sinon sélectionner une plage qui contient 10 fois la valeur 1.1 et collage spécial ( Alt,L,V,G) en cochant les critères valeurs et multiplication


#6

@VANIERS

Bonjour, si ton problème est résolu, merci de sélectionner.


#7

Bonjour,

Je reprécise ma question :
Je désire multiplié les valeurs de 1 à 10 par 1,1 et celles au dessus reste multiplié par 1.
Merci.


#8

Bonjour,

Je reprécise ma réponse,


#9

Bonjour
Ma réponse ci dessus ne modifie que les 10 premières valeurs
http://forum.formuleexcel.com/t/calculer-une-valeur-ponderee/250/5?u=docteurexcel

Un fichier d’exemple ne serait pas de refus


#10

Tableau de répartition de service SES .xls (62,5 Ko)
Bonjour,
Je souhaiterai donc une formule pour calculer automatiquement la pondération indiqué dans le fichier joint (heure de première chaire). Il s’agit donc pour chaque colonne de multiplier les nombres des cellules E15 à E43 par 0.1 le résultat finale ne pouvant pas être supérieur à 1 (seules les dix premières heures sont prise en compte).
Merci.


#11

Bonjour @VANIERS,

Tu étais parti en vacance :grinning:

Bon si j’ai bien compris:

En “E125”

=SI(SOMME(E35:E38;E42:E49;E53:E62;E66:E71;E75:E78;E82:E91;E99:E108;E112:E117)*0,1>1;1;SOMME(E35:E38;E42:E49;E53:E62;E66:E71;E75:E78;E82:E91;E99:E108;E112:E117)*0,1)

Cordialement.


#12

Re @VANIERS,

En y réfléchissant, on peut faire plus court.

En “E125”

=MIN(SOMME(E35:E38;E42:E49;E53:E62;E66:E71;E75:E78;E82:E91;E99:E108;E112:E117)*0,1;1)

Cordialement.


#13

Bonjour,

Euh non, mais avec l’organisation du Bac, j’avais laissé un peu de côté ce dossier. Merci pour cette formule qui convient parfaitement. Maintenant, les emploi du temps, c’est mon chantier d’été… :frowning:


#14

Bonjour @VANIERS,

Si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Merci.

Cordialement.