Calcule et référence

salut tous et a toutes!
ci-joint un fichier excel 2007 a démystifier

.

Bonjour,

Les données n’étant pas triées, une colonne supplémentaire en A qui peut ^étre soit masquée ou avec police en blanc

caesars.xlsx (11,2 Ko)

Bonsoir @j.caesars,
Salut @Mimimathy, :wink:

Une contribution, malgré le fait que nous soyons obliger de reconstituer un fichier avec comme base une image qui aurait toute sa place pour être traitée avec Photoshop :face_with_raised_eyebrow:

Déjà je crée une liste sans doublons dans une colonne “M” pour l’exemple afin de pouvoir faire une liste déroulante en “F2”.

En “M2”

=SIERREUR(INDEX(ColB;EQUIV(0;INDEX(NB.SI(M$1:M1;ColB);0;0);0)); "")

Tirer vers le bas autant que nécessaire.

Puis:
En “G2”

=SIERREUR(INDEX(ColC;PETITE.VALEUR(SI(ColB=$F$2;LIGNE(ColB)-1);LIGNE(A1)));"")

Formule matricielle a valider avec les touches ctrl + maj + entrée

Tirer vers le bas autant que nécessaire.

En “H2”

=SIERREUR(RECHERCHEV(G2;Tableau;2;0);"")

Tirer vers le bas autant que nécessaire.

Voir aussi dans le “Gestionnaire de noms”.

Formules du “Gestionnaire de noms”.

ColB=DECALER(Feuil1!$B$2;;;NBVAL(Feuil1!$B:$B))
ColC=DECALER(ColB;;1;)
ColD=DECALER(ColB;;2;)
SansDoublons|=DECALER(Feuil1!$M$2;;;NBVAL(Feuil1!$M:$M))
Tableau=DECALER(Feuil1!$C$2:$D$2;;;NBVAL(Feuil1!$C:$D))

La liste déroulante en “F2”.

Fichier exemple ICI==> Test.xlsx (13,0 Ko)

Cordialement.

1 J'aime