Calcul de moyenne coefficientée

Bonsoir,

Je souhaite calculer une moyenne avec plusieurs notes coefficientées.

Le problème est que je ne souhaite pas intégrer les absences (considérées comme des zéros par Excel).

Ma formule actuelle est donc celle-ci :
=SOMMEPROD($B$5:$E$5;B6:E6)/SOMME($B$5:$E$5)

ci-dessous une capture d’écran :

excel%20forum%20aide

Merci à ceux qui m’aideront.

Sam

Bonsoir Sam

Pourriez-vous nous donnée un classeur EX :

voici la procédure a suivre pour un classeur EX:

Joindre%20un%20fichier

Cdlt

@kiss6

Bonjour @sam,
Salut @kiss6, :wink:

@sam, a tester:

=SOMMEPROD(($B$5:$E$5)*B6:E6)/SOMMEPROD(($B$5:$E$5)*(B6:E6<>""))

Tirer vers le bas autant que nécessaire.

Cordialement.

1 J'aime

Bonjour Sam

je vous est concocté un petit classeur avec les données que vous décrivez si dessus

Avec formule Matriciel “CTRL+MAJ+ENTREE” sur votre clavier

Cette formule est a tirer vers le bas autant de fois que nécessaire

le casseur ===>Calcul de Moyenne .xlsx (10,8 Ko)

Cdlt

@kiss6

Re,

Bonjour @mdo100

Nous avons envoyé un message en même temps

D’après votre formule j’en conclu que la mienne n’est pas bonne

Bon Sam feras le bon choix

Cdlt

@kiss6

1 J'aime

Re @kiss6, :wink:

Je me suis permis de squatter ton classeur. :yum:

A voir ==>ICI Calcul de Moyenne V1.xlsx (11,1 Ko)

Amicalement.

Re,

je viens de mettre votre formule sur le classeur mais votre formule reste sur “Dorian”

C’la ne serait pas mieux si elle resterais sur le coefficient

Calcul de Moyenne .xlsx (10,9 Ko)

Cdlt

@kiss6

Re @kiss6,

Es-tu certain de ce que tu dis :interrobang:
La première formule était basée sur le premier post de @sam, mais ensuite je l’ais modifié sur le classeur que tu as fourni.

Cdlt.

Re,

C’est juste une question???

Puisque vous mettez les “$$ sur B5:E5” donc vous rester sur “Dorian” NON!!!

Cdlt

@kiss6

Re,

A OK

Autant pour moi je n’avais pas ouvert votre classeur excuser moi

Désoler

Cdlt

@kiss6

Re @kiss6,

Ne soit pas désolé, ça t’en couteras un apéro, :yum: mais comme je ne bois pas d’alcool, ce sera un café :stuck_out_tongue_winking_eye:

Bonne journée.

Re,

Merci et comme mois ces pareil je ne bois pas d’alcool c’la feras deux café

bonne journée a vous

Cdlt

@kiss6

1 J'aime

Re;

Pour Sam un petit supplément voir Classeur

===>Calcul de Moyenne .xlsx (11,0 Ko)

Cdlt

@kiss6

1 J'aime

Bonjour à tous,

Une autre formule
=SOMMEPROD(($B$4:$E$4)*B5:E5)/NB(B5:E5)/2

1 J'aime

Re tout le monde,
Salut @Mimimathy, :wink:

Formule un peu plus courte, je la note dans mes archives.

Pour compléter le petit supplément de @kiss6 en cas d’égalité :blush:

Classeur ICI==> Calcul de Moyenne Pondérée.xlsx (12,1 Ko)

Cordialement.

Re MDO

ATTENTION quand même
la formule fonctionne si le barème est identique :wink:

Re @Mimimathy,

Tout a fait d’accord avec toi.

Mais j’en ais une autre qui traîne dans mes cartons en cas de barèmes différents.

Bonne journée à toi.

Bonjour,

Merci à vous trois pour vos formules.

J’ai retenu celle de mdo100. Il me reste désormais à comprendre la fin mais j’ai du temps pour cela.
La prochaine fois je penserai aux numéros de lignes et colonnes :thinking:

Bon dimanche et encore merci. :smiley:

sam

Re,

Si votre problème est résolue veuillez

:white_check_mark: Marque la bonne réponse en cochant ce symbole sous le message :white_check_mark: C’est notre formule de politesse ici!

et c’la nous permet de voir qui a encore besoin d’aide

@mdo100 , J’ais rectifié le classeur ,au passage merci a @Mimimathy pour la participation

@mdo100 ma formule pour le rang n’est tout a fait fausse puisqu’il y a des exæquos

===>Test-V2.xlsx (711,2 Ko)

Cdlt

@kiss6

Re @kiss6,

Si tu avais regardé mon classeur attentivement et lu mon post correctement.

Tu aurais pu voir qu’il n’y a aucune agressivité dans mon langage et que le but de ma formule est de départager les exæquos au cas ou il y en aurait.

Donc je n’ais jamais dit que ta formule était fausse, de plus je ne fais pas d’abus de signe de mécontentement de ce genre ( :face_with_raised_eyebrow: ) qui est plutôt très désagréable venant de ta part.

Dernière chose, le dernier classeur que tu as joins, ne correspond absolument pas au sujet du jour.

Bonne fin de journée.
Cdlt.