Calcul de différence en pourcentage

Bonjour,
J’ai un formule “simple” qui me calcule la différence entre deux nombres dans Excel (par exemple: “=(
A16-A15)/A15”
Par contre, lorsqu’une cellule est à zéro, la formule donne une erreur (division par zéro pas possible).
Auriez-vous une solution à me proposer?

https://drive.google.com/open?id=11t0PAryK5c8BQZ4r-qz5juynaOcQ6NaI

Bonjour pperet75,
Une solution possible est d’effectuer un test sur le contenu d’une cellule
Dans ton fichier tu as écris la formule suivante :
=(A14-A13)/A13

Essaie de modifier ta formule par celle-ci :
=SI(A13=0;"";(A14-A13)/A13)

Bien à toi et bon travail

Bonjour CordierEt,
Alors effectivement, l’erreur n’est plus présente, par contre, aucun calcul ne se fait du coup…
Si j’ai “0” dans une cellule, et “200” dans la suivante, j’aimerais que le pourcentage affiché soit “200%” et non une cellule vide.
Mais merci quand même… on avance

Voici une autre proposition qui évite d’avoir une cellule vide
=SI(A13=0;1;(A14-A13)/A13)

Bien à toi

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.