Besoin d'aide pour un classement Top7

Bien le Bonjour à tous !

Tout d’abord je vous souhaite une bonne et heureuse année 2019. Santé et prospérité.

J’ai un soucis sur un tableur excel dont Mimi avait fait des prouesses en 2018. J’ai une formule qui me donne le top5 des points réalisé par une personne.
la formule est :
=SIERREUR(SI(T6>=5;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3;4;5}));SI(T6=4;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3;4}));SI(T6=3;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3}));SI(T6=2;SOMME(GRANDE.VALEUR(A6:K6;{1;2}));SI(T6=1;SOMME(GRANDE.VALEUR(A6:K6;1));0)))));"")

Pour cette année, j’ai besoin de prendre les 7 meilleurs performance de chaque joueur.
Bien entendu, j’ai essayé de moodifier la formule en y ajoutant le complément nèccessaire, c’est à dire :
=SIERREUR (SIT6>=7;SOMME (GRANDE.VALEUR(A6:K6;{1;2;3;4;5;6;7}));SI(T6=6;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3;4;5;6}));SI(T6=5;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3;4;5}));SI(T6=4;SOMME(GRANDE.VALEUR(A6:K6;{1;2;3;4}));SI(T6=3;SOMME(GRANDE.VALEUR(A6:K6;1;2;3));SI(T6=2;SOMME(GRANDE.VALEUR(A6:K6;{1;2}));SI(T6=1;SOMME(GRANDE.VALEUR(A6:K6;{1}));0)))));"")

Mais cette formule modifié ne fonctionne pas. Si quelqu’un pouvait m^'aider svp.

Le lien du fichier https://mon-partage.fr/f/b6cXzAZm/
sur l’onglet janv/fev/mars pour m’aider.

Merci à vous

Je précise qu’une formule raccourci c’est à dire :
=SIERREUR(SI(T15>=7;SOMME(GRANDE.VALEUR(B15:P15;{1;2;3;4;5;6;7}));SI(T15=4;SOMME(GRANDE.VALEUR(B15:P15;{1;2;3;4}));SI(T15=3;SOMME(GRANDE.VALEUR(B15:P15;{1;2;3}));SI(T15=2;SOMME(GRANDE.VALEUR(B15:P15;{1;2}));SI(T15=1;SOMME(GRANDE.VALEUR(B15:P15;1));0)))));"")
fonctionne lorsqu’il y a 7 résultat au minimum mais si j’ai moins de 7 résultat, cela m’affiche zéro et je souhaiterai que ca m’affiche la somme additionnée.

Merci

Bonjour @mike02840,

Meilleurs Vœux 2019.
https://forum.formuleexcel.com/t/excel-lente-annee-2019/3975/3

A tester en “R5”

=SIERREUR(SI(T5>=7;SOMME(GRANDE.VALEUR(B5:P5;{1;2;3;4;5;6;7}));SI(T5=6;SOMME(GRANDE.VALEUR(B5:P5;{1;2;3;4;6}));SI(T5=5;SOMME(GRANDE.VALEUR(B5:P5;{1;2;3;4;5}));SI(T5=4;SOMME(GRANDE.VALEUR(B5:P5;{1;2;3;4}));SI(T5=3;SOMME(GRANDE.VALEUR(B5:P5;{1;2;3}));SI(T5=2;SOMME(GRANDE.VALEUR(B5:P5;{1;2}));SI(T5=1;SOMME(GRANDE.VALEUR(B5:P5;1));0)))))));"")

Puis tirer vers le bas autant que nécessaire.

Cordialement.

PS: Au passage je passe un p’tit salut à @Mimimathy :wink:

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.