Automatiser un fichier Excel


#1

Bonjour,
Je souhaite automatiser un fichier Excel, de tel sorte que mon onglet synthèse aille chercher les informations du mois concerné, ainsi que le cumul à date dans un onglet détail.
Je veux en effet sélectionner le mois concerné et avoir toutes les infos.

Quelle formule utiliser ?
Merci d’avance de votre aide.

Belle journée à vous !

Gab


#2

Bonjour @Gaby,

Nous avons besoin de la structure de ton fichier, pour élaborer une solution.

Peux-tu joindre un fichier, pour cela suivre les instructions ci-dessous.

Joindre un fichier

Cordialement.


#3

Classeur1.xlsx (15,3 Ko)

Voila le fichier.

Je veux pouvoir mettre à jour mon onglet “Synthèse (2)”, en cliquant sur le bon mois.
Exemple: lorsque je sélectionne Juillet, le mois (en colonne B et C) ainsi que le cumul (en colonne D et E) se mettent à jour.

Merci d’avance pour ton aide !


#4

Re @Gaby,

Ce que l’on peut dire, c’est que tu n’as pas fait un gros effort dans la présentation de ton fichier:

Rechercher un mois et année 2017 sur des mois et années 2016 ???

Bref, voici une proposition:

Dans la feuille “Synthèse(2)” en “A1” liste des mois.

En “B3”

=SOMMEPROD(('P&L Mois (2)'!$B$1:$G$1>=$A$1)*('P&L Mois (2)'!$B$1:$G$1<=$A$1)*(Entête=B$2)*('P&L Mois (2)'!$B4:$G4))

En “C3”

=SOMMEPROD(('P&L Mois (2)'!$B$1:$G$1>=$A$1)*('P&L Mois (2)'!$B$1:$G$1<=$A$1)*(Entête=C$2)*('P&L Mois (2)'!$B4:$G4))

En “D3”

=SOMMEPROD(('P&L Mois (2)'!$B$1:$G$1>=$A$1)*('P&L Mois (2)'!$B$1:$G$1<='P&L Mois (2)'!$G$1)*(Entête=D$2)*('P&L Mois (2)'!$B4:$G4))

En “E3”

=SOMMEPROD(('P&L Mois (2)'!$B$1:$G$1>=$A$1)*('P&L Mois (2)'!$B$1:$G$1<='P&L Mois (2)'!$G$1)*(Entête=E$2)*('P&L Mois (2)'!$B4:$G4))

Tirer les formules vers le bas autant que nécessaire.

Et un petit bout de VBA dans la feuille “Synthèse(2)”.

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Calculate
End Sub

Ce qui évite d’appuyer sur la touche ( F9 ) pour actualiser la feuille lors du changement de mois en “A1”.

Ci joint le fichier ICI==> Gaby V1.xlsm (21,8 Ko)

Cordialement.


#5

Bonsoir Mdo100,
Grand merci à vous. J’essaierai ça demain et vous direz si ça marche.
Et oui, j’aurai dû faire un effort sur la présentation :grin:.
Excellente soirée à vous.