Attribution de numéro unique aléatoire pour une liste de noms


#1

Bonjour,

Je suis nouvelle sur ce Forum (et tout autant sur Excel). Conséquemment, mes connaissances sur le logiciel s’avèrent très de base. Voici: j’ai une liste de 18 noms et prénoms (colonnes A et B) auprès desquelles je désire attribuer à chaque nom (prénom) un numéro unique de manière aléatoire afin de procéder à un tirage. J’ai essayé la fonction =ALÉA(), mais sans résultat. Que me conseillez-vous? Merci de votre aide!


#2

Bonsoir @smartpolice,

La prochaine fois évite de mettre ton message entre les balises pour insérer un code ou formule. :stuck_out_tongue_winking_eye:

Bon, je t’explique:

J’ai mis en colonnes “A&B” les 18 Noms & Prénoms.

Ensuite je les ais concaténés avec cette formule en colonne “C”.

=A2&" "&B2

Dans la colonne “D” tu mets un “x” pour sélectionner les noms & prénoms.

Dans la colonne “E” affiche les noms & prénoms sélectionnés avec cette formule.

=SI(D2="x";C2;"")

Dans la colonne “F” attribution d’un N° aléatoire unique avec cette formule.

=SI(D2="x";ALEA();0)

Dans la colonne “H” tu choisis le nombre de participants, j’en ais mis 5 au hasard.

Dans la colonne “I” je choisis les 5 grandes valeurs de la liste des N° d’attribution aléatoire avec cette formule.

=SI(H2<>"";GRANDE.VALEUR($F$2:$F$19;H2);"")

Enfin en colonne “J”, je recherche les noms & prénoms correspondant.

`=INDEX($C$2:$F$19;EQUIV(I2;$F$2:$F$19;0);1)

Faire un appuis sur la touche “F9” du clavier pour faire un autre tirage au sort.

Ci- joint un fichier exemple ICI==> smartpolice V1.xlsx (13,6 Ko)

Cordialement.