Afficher une valeur selon un intervalle

Bonjour,
Je souhaite afficher dans une cellule C6 la mention « NC » si la valeur de l’écart cellule B4 n’est pas comprise entre la valeur ± cellule A1. Mais si la valeur est comprise dans la valeur EMT cellule A1 cela affiche « C ».
J’étais sur cette formule =SI(D4="";"";SI(B4>A1;“NC”;“C”)) Mais dès que la valeur de la cellule B4 passe en négatif cela me « C » au lieu de « NC »
A1 = L’écart maximum = ±5
B4 = valeur de l’écart = -5.67
D4 = Valeur du contrôle = 37.8
Si vous avez un tuto ou réponse à m’apporter, cela serai avec plaisir.
Cordialement
Jérôme

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?

Merci et à bientôt

Bonjour jerome_kara, @DocteurExcel,

Un essai si j’ai bien compris:

=SI(D4="";"";SI(OU(B4>=+A1;B4<=-A1);"NC";"C"))

Ou:

=SI(D4="";"";SI(OU(B4>+A1;B4<-A1);"NC";"C"))

Cordialement.

2 J'aimes

Bonjour
Salut MDO

Si j’ai compris, car au départ il est normal qu’une valeur négative te renvoi le résultat, mais n’ayant pas plus de renseignement, la formule de MDO convient très bien et peut-être simplifiée par la fonction ABS() qui ne prend en charge que la valeur ABSolue (CàD sans les signes)

=SI(D4="";"";SI(ABS(B4)>A1;"NC";"C"))

1 J'aime

Salut @Mimimathy,

Bien vu :eyes:

Tu pouvais mettre aussi l’autre solution simplifié et plus courte que ma formule. :wink:

=SI(D4="";"";SI(ABS(B4)>=A1;"NC";"C"))

Trop fort @Mimimathy :muscle:

Amicalement.

Merci beaucoup!

-------- Message d’origine --------

Bonjour,
=SI(D4="";"";SI(ABS(B4)>=A1;“NC”;“C”))
Je vous remercie pour cette formule car elle fonctionne très bien! vous étés des vrai pro!!

Grand MERCI!

Re,
N’oublies pas de passer ton post en RESOLU sur le post de MDO :wink: